iamgenet file not found 'networks/bvlc_googlenet.caffemodel ...

Hello there!

I’m trying to complete “two days to a demo”.

I followed the guide provided at https://developer.nvidia.com/embedded/twodaystoademo

I get into “Using the Console Program on Jetson” but it looks like something is missing.

when using this command:

$ ./imagenet-console orange_0.jpg output_0.jpg

I got this response:

imagenet-console
args (3): 0 [./imagenet-console] 1 [orange_0.jpg] 2 [output_0.jpg]

imageNet – loading classification network model from:
– prototxt networks/googlenet.prototxt
– model networks/bvlc_googlenet.caffemodel
– class_labels networks/ilsvrc12_synset_words.txt
– input_blob ‘data’
– output_blob ‘prob’
– batch_size 2

[GIE] TensorRT version 2.1, build 2102
[GIE] attempting to open cache file networks/bvlc_googlenet.caffemodel.2.tensorcache
[GIE] loading network profile from cache… networks/bvlc_googlenet.caffemodel.2.tensorcache
terminate called after throwing an instance of ‘nvinfer1::CudaError’
what(): std::exception
Aborted (core dumped)

I looked at https://devtalk.nvidia.com/default/topic/1019986/jetson-tx1/getting-errors-in-using-onboard-camera-jetpack-3-1-/3 but is a TX1 board and also seems not solved.

I am missing something?

I tried to reinstall and build from scratch jetson-inference folder again but same message appears.

Note: Inside networks directory, there is not bvlc_googlenet.caffemodel.2.tensorcache file, there is bvlc_googlenet.caffemodel instead.

thanks for your time !

are you following the guide provided at https://github.com/dusty-nv/jetson-inference/blob/master/README.md ?
specifically https://github.com/dusty-nv/jetson-inference/blob/master/README.md#building-from-source-on-jetson ?

Hi Andrey,

I installed cuDNN, NVcaffe and Digits on the HOST.

I Didn’t test yet but digits seems to be ready and OK.

When I get into “building from source on Jetson” I followed step by step until using imagenet-console, which is giving me the error.

I search for driver’s versions with

head -1 /etc/nv_tegra_release

and got this:

R28 (release), REVISION: 1.0, GCID: 9379712, BOARD: t186ref, EABI: aarch64, DATE: Thu Jul 20 07:59:31 UTC 2017

I saw there is a REVISION 2.0 but I don’t know how to upgrade or if it’s necessary.

Thanks again

when you are doing “building from source on Jetson”
what instruction steps you are following?
try https://github.com/dusty-nv/jetson-inference/blob/master/README.md#building-from-source-on-jetson

how to reproduce the error and what is the content of the error message?

if you are using tx2 flashed from Jetpack 3.1, you may also try Jetpack3.2 that will have R28.2

I will try that so.

Thanks !

Well, it was a sudo restriction.

I need to sudo the command, now it’s working fine.