segmentation fault when ./imagenet-console orange_0.jpg output_0.jpg on tx2

I install jetson-inference and build it.

After build I tried ./imagenet-console orange_0.jpg output_0.jpg

then segmentation fault occurs.

[b]nvidia@tegra-ubuntu:~/jetson-inference/build/aarch64/bin$ ./imagenet-console orange_0.jpg out.jpg
args (3): 0 [./imagenet-console] 1 [orange_0.jpg] 2 [out.jpg]

imageNet – loading classification network model from:
– prototxt networks/googlenet.prototxt
– model networks/bvlc_googlenet.caffemodel
– class_labels networks/ilsvrc12_synset_words.txt
– input_blob ‘data’
– output_blob ‘prob’
– batch_size 2

[GIE] attempting to open cache file networks/bvlc_googlenet.caffemodel.2.tensorcache
[GIE] cache file not found, profiling network model
[GIE] platform has FP16 support.
[GIE] loading networks/googlenet.prototxt networks/bvlc_googlenet.caffemodel
Segmentation fault (core dumped)

What should I do?

Hi jseshoo, it looks like maybe your bvlc_googlenet.caffemodel may be corrupted. This file is automatically downloaded by a script during the cmake step of building the repo. You can see all the model URLs in this file.

Can you try running these commands?

$ cd jetson-inference/data/networks
$ wget

Then try running the program again. If you still get failure, remove the build directory and try building again, which will re-download the files:

$ cd jetson-inference
$ rm -r -f build
$ mkdir build
$ cd build
$ cmake ../
$ make