Iasaac_ros_argus_camera fails to start: GXF Error

I am trying to run isaac_ros_argus_camera in an isaac_ros-dev container. when I try to launch argus_camera, it is shows this error

[component_container_mt-1] 2024-03-19 19:25:12.667 ERROR /data/jenkins/ros/workspace/ly_debian-compatible-release-2.1/isaac_ros-dev/ros_ws/src/isaac_ros_image_pipeline/isaac_ros_image_proc/gxf/tensorops/extensions/tensorops/components/TensorStream.cpp@104: tensor stream creation failed. [component_container_mt-1] 2024-03-19 19:25:12.667 ERROR gxf/std/entity_warden.cpp@406: Failed to initialize component 00054 (stream) [component_container_mt-1] 2024-03-19 19:25:12.667 ERROR gxf/core/runtime.cpp@685: Could not initialize entity 'MQOITDTRKR_global' (E52): GXF_FAILURE [component_container_mt-1] 2024-03-19 19:25:12.667 ERROR gxf/std/program.cpp@236: Failed to activate entity 00052 named MQOITDTRKR_global: GXF_FAILURE [component_container_mt-1] 2024-03-19 19:25:12.667 ERROR gxf/std/program.cpp@238: Deactivating... [component_container_mt-1] 2024-03-19 19:25:12.668 ERROR gxf/core/runtime.cpp@1384: Graph activation failed with error: GXF_FAILURE

Here is a complete error log error.txt (9.4 KB)

I did try the solution mentioned in this post. It did not work for me.

Could you please help me debug this issue?

My Setup:
Jetson Orin Nano 8Gb with Devkit
JetPack 5.1.2
isaac_ros_argus_camera inside of jetpack dev container.
GMSL 2 camera connected to CSI Port 1. ( Works fine with V4L2 driver)

Thank you!

Hi, @bnbhat

I will describe the order of my actions as it helped me

  1. Disabled the desktop GUI instruction i used disable desktop on boot;

  2. Reboot jetson;

  3. And only then executed the command:

    $ xinit &
    output above command
    X.Org X Server 1.20.13
    X Protocol Version 11, Revision 0
    Build Operating System: linux Ubuntu
    Current Operating System: Linux ubuntu 5.10.120-tegra #1 SMP PREEMPT Tue Aug 1 12:32:50 PDT 2023 aarch64
    Kernel command line: root=PARTUUID=13bdaaba-0db2-4d1a-a3f7-d2b6c5e77866 rw rootwait rootfstype=ext4
    mminit_loglevel=4 console=ttyTCU0,115200 console=ttyAMA0,115200 firmware_class.path=/etc/firmware
    fbcon=map:0 net.ifnames=0 nospectre_bhb nv-auto-config
    Build Date: 29 January 2024  12:44:21PM
    xorg-server 2:1.20.13-1ubuntu1~20.04.15 (For technical support please see http://www.ubuntu.com/support)
    Current version of pixman: 0.38.4
           Before reporting problems, check http://wiki.x.org
           to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
            (++) from command line, (!!) notice, (II) informational,
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Wed Mar 20 11:19:06 2024
    (==) Using config file: "/etc/X11/xorg.conf"
    (==) Using config directory: "/etc/X11/xorg.conf.d"
    (==) Using system config directory "/usr/share/X11/xorg.conf.d"
  4. Check that display :0 initialized:

    $ echo $DISPLAY
  5. Restart the docker containers, and make sure that the display :0 is set.

And that solved the problem for me.


Thank you @Nikolay196

the workaround you posted is a great solution, but we are working on a new release that will fix this bug.


1 Like

Thank you @Nikolay196 for the detailed instructions. It did solve the issue.

@Raffaello I am trying to get isaac_ros_argus_camer driver working with a camera, which is not listed as
supported/tested in the documentation. Are there any instructions on integrating other camera modules with the driver?

I am using a Sony ISX031C-based camera with a GMSL2 link.

Thank you!

hi @Nokolay196,
I have the same problem when using isaac_ros_h264_decoder package(Hardware: Orin NX).

I did the first 4 steps of your solution( the 4th step is export $DISPLAY =:0 into the .bashrc).
then,I performed the 5th step(with cmd:docker start -i), the error info is still existed.

so, did I have lossed some steps?

Hi, @skyun2012

I did not fully describe the steps and missed the point, if you connect to the board via ssh with the -X flag:

ssh -X user@server

or use, for example, a mobaxtrem client that automatically initializes the x11 server when connected to the board, the display environment variable will look like something like this:

$ echo $DISPLAY

And after starting the console, in the docker container in which you want to run isaaac_ros_h264_decoder, set the environment variable display = 0

export DISPLAY=:0

And then the problem will most likely disappear

But as Raffaello said, this problem will be solved in another way, this is a temporary solution.

1 Like

Mobaxterm happens to be the tool that I’m using.
According to your advice,now it works, Thank you very much!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.