Import keras requires Tensorflow 2.2 or higher

When do we get access to tensorflow 2.2 on jetson nano . I get error while importing keras.

Error: Keras requires TensorFlow 2.2 or higher. Install TensorFlow via `pip install tensorflow

Although tensorflow 2.1 is already installed

Hi,

Do you install TensorFlow from our official release?

It looks like keras v2.4.3 requires higher TensorFlow package now.
Would you mind to use previous keras release to skip this issue?

$ sudo pip3 install keras==2.3.0

Thanks.

Let me try this , thanks for your response

Hi,

Just FYI.

We release a new TensorFlow package yesterday, which is v2.2.0.

$ sudo pip3 install --pre --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v44 tensorflow==2.2.0+nv20.6

Thanks.

1 Like