"ImportError: libcudnn.so.6" When using TensorFlow

Hey guys. I’m trying to get TF working but it is giving me the error:
ImportError: libcudnn.so.6: cannot open shared object file: No such file or directory

I searched around and found that the Envvar LD_LIBRARY_PATH needs to be set and also that I need Cudnn 6 installed. I downloaded it from nvidia and installed to /usr/local/cuda/lib64 and linked the EnvVar to the directory. Now I can run $LD_LIBRARY_PATH/libcudnn.so.6 and it finds the file. However TF still throws the error that it cannot find the file! What can I check next?

I used the wheel file provided by JetsonHacks on github to install TF.
I’m on a Jetson tx1.

Thanks!

Bump

One thing that worked for me was that rather than using 'export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/usr/local/cuda/lib64" ’ I used 'export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:~/cuda/lib64" ’ and it worked. I have to do it everytime the computer starts. Dont know what is cuda doing in my home folder and don’t know why I need to do it everytime.

Hi ssullivan

Did you get it to work?

I have the same problem.

sojohans

Yes. I had to reinstall cudnn with jetpack. The file was the wrong version even though it had the right name.