Incomplete cuDNN 7.6.5 installation

I have CUDA 10.1 and trying to install cuDNN 7.6.5 in order to meet GPU requirements for Tensorflow 2.3.0. OS is Ubuntu 18.04 and GPU is GeForce GTX 1050 Mobile.

I had previously installed cuDNN 8 but uninstalled in order to meet tf GPU requirements. After installing, I can find cudnn.h, but I am missing libcudnn.so.7. I cannot find it in my CUDA folders nor in /usr/lib/x86_64-linux-gnu. However, I can find libcudnn.so in /usr/local/cuda-10.1/lib64. The reason I’m looking for libcudnn.so.7 is because I get this error when I run tf.config.list_physical_devices('GPU') in python:

W tensorflow/stream_executor/platform/default/dso_loader.cc:59] Could not load dynamic library 'libcudnn.so.7'; dlerror: libcudnn.so.7: cannot open shared object file: No such file or director

Any feedback is appreciated

Maybe you could fix your issue with a symbolic link:
ln -s libcudnn.so libcudnn.so.7

My situation (cuDNN8 for CUDA 11.1) is that I have the same error message “Could not load dynamic library 'libcudnn.so.7” but no libcudnn.so files at all in my /usr/local/cuda-11.1/lib64 directory.

I was able to resolve other missing libraries with symbolic links:
libcudart.so.10.1 -> libcudart.so.11.1.74
libcublas.so.11 -> libcublas.so.11.2.1.74
libcusolverMg.so.11 -> libcusolverMg.so.11.0.0.74
libcusparse.so.11 -> libcusparse.so.11.2.0.275

I ended up fixing this issue a while ago, but I think I (1) made sure I installed the proper version of CUDA/tensorflow/etc and (2) added relevant symlinks