In Fedora 37 nvidia-driver 520.56.06 is buged and crash Apex legend [drm:nv_drm_fence_context_create_ioctl [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID

In Fedora 37 , with nvidia-driver 520.56.06 from rpmfusion it crash Apex legends in game sometime with the driver in rpmfusion i cannot play properly like some peoples in reddit also

The rpmfusion bug i open 6466 – [drm:nv_drm_fence_context_create_ioctl [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to allocate fence signaling event

I cannot link the reddit and fedora forum because i’m a new account but they are in the bugzilla

The same error are here in wayland or x11

[ 74.206924] nvidia: loading out-of-tree module taints kernel.[ 74.206932] nvidia: module license ‘NVIDIA’ taints kernel.[ 74.206933] Disabling lock debugging due to kernel taint[ 74.215326] nvidia: module verification failed: signature and/or required key missing - tainting kernel[ 74.292585] nvidia-nvlink: Nvlink Core is being initialized, major device number 235[ 74.293393] nvidia 0000:01:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=io+mem[ 74.337681] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 520.56.06 Thu Oct 6 21:38:55 UTC 2022[ 74.390754] nvidia_uvm: module uses symbols nvUvmInterfaceDisableAccessCntr from proprietary module nvidia, inheriting taint.[ 74.416584] nvidia-uvm: Loaded the UVM driver, major device number 511.[ 74.457747] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms 520.56.06 Thu Oct 6 21:22:53 UTC 2022[ 74.461978] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver[ 75.953450] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 0
[ 510.516218] [drm:nv_drm_fence_context_create_ioctl [nvidia_drm]] ERROR [nvidia-drm] [GPU ID 0x00000100] Failed to allocate fence signaling event

Linux fedora 5.19.16-301.fc37.x86_64 #1 SMP PREEMPT_DYNAMIC Fri Oct 21 15:55:37 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
NVIDIA GeForce RTX™ 3060

nvidia-smi Sat Nov 5 02:26:35 2022 ±----------------------------------------------------------------------------+| NVIDIA-SMI 520.56.06 Driver Version: 520.56.06 CUDA Version: 11.8 |

I got this error on Fedora 37 but not on my Fedora 36 with akmod-nvidia-510.68.02-1.fc36.x86_64.rpm

How can i help to debug this ?

Thanks !

I am also affected by this bug.

I can reproduce it by starting Virtualbox with a Windows 11 guest.

Same issue but without crashing on arch 6.0.7 520.56.06 3060ti
Regardless of PowerMizer mode it happens while playing any game at any GPU usage (tried to lower down settings to get to 50% usage as well as tried max settings to get 90% usage) Games: Elden Ring, Dark Souls III, Valheim.

[drm:nv_drm_fence_context_create_ioctl [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000500] Failed to allocate fence signaling event

I removed nvidia-drm.modeset=1 from kernel parameters and I don’t get this error anymore.

(removing it can break PRIME afaik, should be safe for PC if you don’t use hybrid graphics)

It is still present in Nvidia 525. Do the open gpu kernel works better?

Hello, I have the same problem on Arch linux. I have Lenovo Legion 5 15IMH05H with Intel integrated and Nvidia dedicated graphics. (RTX 2060 and i5-10300H)

I have tested multiple nvidia driver versions and multiple kernel versions, I do not remember everything, but the latest 520.56.06 crashes, 510 crashes, I have also tried some 4xx versions like 470 and others, all crashed with nothing in the logs except

kernel: [drm:nv_drm_fence_context_create_ioctl [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to allocate fence signaling event

Once I saw this error:

kernel: [drm:drm_new_set_master] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to grab modeset ownership

I have tried dkms and non dkms versions, kernels 5 and 6, lts, zen, standard arch kernel versions, don’t remember exactly but I have not found any combination which would work and not crash.

When I turn off the intergrated intel gpu in UEFI and turn off modesetting (using the nvidia_drm.modeset=0 kernel parameter), everything works as expected, but this is not really viable - working PRIME offload is the obvious goal here.

One guy on arch forums said that nvidia 515 from AUR worked for him, so I went and force-installed it for testing.
Now on 6.0.8-zen1-1-zen and nvidia-dkms-6 and nvidia-utils-6 from AUR: Interestingly enough, the errors disappeared from logs BUT it still crashes (kinda hilarious tho annoying), tho there can be more time between crashes, i.e. it will crash in 10 minutes to 2 hours - on other driver and kernel version combinations it always crashed under 15 minutes after starting Metro Last Light Redux on the dedicated nvidia using PRIME offload.

Also another strange thing: When I start minecraft, often the screen tends to ‘freeze’ but without a crash, I can ‘fix’ it switch to any tty and back. Also, this happens when I use my i3 binding to make minecraft full-screen - the screen freezes and I have to switch to tty and back, I have to use the fullscreen setting in minecraft so the screen doesn’t freeze …and it also crashes.

I’ll be happy to help and supply additional logs and stuff.
Hope all of this was understandable.

Hey there, I randomly stumbled upon this:

Seems similar to our issue here.

Hey, the reason for this issue has been found. The bug still exists in driver “VIDIA-SMI 525.89.02 Driver Version: 525.89.02 CUDA Version: 12.0”.

It affects most/all DirectX 12 games running via VKD3D. The symptom: They hang at startup, freezing the entire computer for a few minutes at a time so that not even the mouse cursor can render, and then the game rolls smoothly for a little while, until it suddenly freezes the computer again.

But be aware… VKD3D coded a workaround to disable the broken Vulkan extensions in NVIDIA’s driver. So if you want to troubleshoot the issue and reproduce it internally, you need to build VKD3D from source and remove both of the bugfixes mentioned below:

There are two fixes for NVIDIA bugs there. The Vulkan present id/wait hang, and some queue/work related hang. Those bugs will be masked by VKD3D if you don’t remove those workarounds. :)