When I was running this code block:

Some weather Intent queries

queries = [
“Is it currently cloudy in Tokyo?”,
“What is the annual rainfall in Pune?”,
“What is the humidity going to be tomorrow?”
for q in queries:
req = jnlp.AnalyzeIntentRequest()
req.query = q
start = time()
resp = jarvis_nlp.AnalyzeIntent(req)


I got this error:

_InactiveRpcError: <_InactiveRpcError of RPC that terminated with: status = StatusCode.UNIMPLEMENTED details = “Method not found!” debug_error_string = “{“created”:”@1619771255.257000000",“description”:“Error received from peer ipv6:[::1]:50051”,“file”:“src/core/lib/surface/call.cc”,“file_line”:1068,“grpc_message”:“Method not found!”,“grpc_status”:12}" >

How to solve it?

Hi @shy0625,
grpc status - 12- The operation is not implemented or is not supported/enabled in this service.

Could you please check the deployment of your service to confirm?
Also, please share the steps and source code to reproduce the error so we can help better.


Hi, we passed by this problem at this moment. Thanks for your help.

I noticed that Jarvis can support five languages including English、Chinese、Japanese and so on.
Could you please tell me how to set the Chinese parameter in Jarvis frame since our conversation
conducts in the Chinese scenario ?

Hi @shy0625,

Could you please refer to below topic in case it helps:


Hi, here is one code block in Jarvis’s official demo:

req = jnlp.AnalyzeIntentRequest()
req.query = “How is the humidity in San Francisco ?”

req.options.domain = “weather” # The <domain_name> is appended to “jarvis_intent_” to look for a
# model “jarvis_intent_<domain_name>”. So in this e.g., the model
# “jarvis_intent_weather” needs to be preloaded in jarvis server. If
# you would like to deploy your custom Joint Intent and Slot model
# use the ‘–domain_name’ parameter in ServiceMaker’s ‘jarvis-
# build intent_slot’ command.

resp = jarvis_nlp.AnalyzaIntent(req)
print (resp)

the question is how to set the ‘–domain_name’ parameter and where to find the ServiceMaker’s ‘jarvis-build intent_slot’ command ?


Here is the links to this question:




Jarvis ServiceMaker tool / Jarvis_User_Guide_Docs

Hi. Please tell me … how did you pass this problem? I have gotten something like yours.

Please help me with it.

Can you help me with it?

hi, we “passed by this problem” by ignoring it at that moment, not really solved it. Sorry for misunderstanding.

Actually I’m tracking the same error as yours and I’ll share the solution as soon as I figure out it.


1 Like

Thank you. Yesterday I was trying to rebuild all containers by lower Jarvis version. but that didn’t Solve the problem.