Includes not working on win 7 x64 with Vs2008prof

Hi Everyone!

Im using win 7 x64, and VS 2008 prof, I have a solution where I have 3 static librarys: 2 regular c++, 1 cuda and a cuda project, which needs to use all of them.
My problem is the following: when i try to build the solution, all the librarys build just fine, but the cuda project does not, because it cannot find the files belonging to the librarys. I have dependencies set up, and also has the correct path-s set up in “additional include directorys” of the project.

Namely: fatal error C1083: Cannot open include file: ‘ga/std_stream.h’: No such file or directory While i have this in the “additional include directorys” e:\Diploma\MOGAlib\galib\ (galib folder does contain “ga” directory, which contains std_stream.h)

Also if i copy the “galib” folder into the project root everythings allright, but I would like to get it straight, not just use some workarounds.
As i remember, this problem first occured, when I started to use the VS wizzard 2.3 instead of the 2.2, so maybe the problem is somewhere in the config changes, what happend between the two versions, but Im totally cluless about this one. Anyways this error also existed when i used Vista x64, so its not a win 7 error.

Another problem, since I started using win 7 setting up the path variable for cutil64D.dll does not work, I’ve done the same, which worked on vista, but now its still bitching about not finding the dll (again copying it to project root helps, but its not the best solution)

–> Ok i managed to solve the dll error, the message only mention cutli64D.dll, but cutil64.dll also have to be set in the Path variable, that solves this problem.

By the way, the sample.cu what the cuda wizzard creates works fine, after i copy the cutil dll to the project root, so the base cuda includes are working fine

Oh and at last. Can anyone tell me what happend to CUDA SDK, I’ve only managed to find Cuda Toolkit 3 on Nvidia’s homepage, I thought ok, its melded with the sdk now, but it does not contain the dll-s which are needed to compile CUDA sources (or maybe I was blind, but it does not work) so I installed Cuda SDK 2.2 which I still had from the last time I worked with CUDA, that maybe also the source of some errors, i dont know.

Thanks in advance!
Exhodus

Any ideas on the include error?? comeon!

Any ideas on the include error?? comeon!