Incorrect time as clock is not persistent in Jetson AGX Xavier


I am using Jetson AGX Xavier kit. It seems that clock is volatile as everytime I turn it on, it shows the icorrect time. Using NTP, I can sync the clock to get the correct time. But I am surprised that it needs to be done at every start up.

BTW, I am using JetPack 4.6 (Ubuntu 18.04 LTS). Below is the other information:

$ ls -l /etc/localtime
lrwxrwxrwx 1 root root 30 Jan  5 15:17 /etc/localtime -> /usr/share/zoneinfo/Asia/Tokyo

$ cat /etc/timezone

$ timedatectl
                      Local time: Wed 2023-04-12 14:57:51 JST
                  Universal time: Wed 2023-04-12 05:57:51 UTC
                        RTC time: Wed 2023-04-12 05:57:50
                       Time zone: Asia/Tokyo (JST, +0900)
       System clock synchronized: no
systemd-timesyncd.service active: yes
                 RTC in local TZ: no

$ head -n 1 /etc/nv_tegra_release
# R32 (release), REVISION: 7.3, GCID: 31982016, BOARD: t186ref, EABI: aarch64, DATE: Tue Nov 22 17:32:54 UTC 2022

I suspect that the coin cell shown in the picture below is dead:

What is the part number? is it possible to replace this cell to fix the broken clock?


You can measure the voltage level of RTC battery when system in power off to make sure if it is dead, and refer to below info from module datasheet.

The following backup cells may be attached to this pin:
Super Capacitor (gold cap, double layer electrolytic)
Standard capacitors (tantalum)
Rechargeable Lithium Manganese cells
The backup cells must provide a voltage in the range 2.5V to 3.5V. These will be charged with a constant current, and a constant voltage charger that can be configured between 2.5V and 3.5V (constant voltage) output and 50 uA to 800 uA (constant current).

Dear @Trumany

Thank you very much.

During power on, it seems keeping a constant voltage of 2.825V as shown on my multimeter.

I haven’t checked the voltage while it is off.

Surprisingly, not only this but other Jetson are also not displaying the correct time after shutdown.

Is the super capacitor dead in all of my Jetson? I wonder!!! On the other hand, what are the other steps to debug this issue? I have checked the time zone and other information shared above.

Thanks again.

Which clock time is missing here? RTC time? What kind of missing is that? back to 1970-1-1?

Dear @WayneWWW

Thank you very much for your response. I am sorry for the confusion.

May I request you to please check my first post above. The command timedatectl showed * Wed 2023-04-12 14:57:51 JST* yesterday. I actually shutdown this Jetson on 12 April sometime in afternoon. Yesterday, when I turned it on, it picked up the time from that day.

Please let me know if you need more information.

Thanks again


It seems not a common issue we saw before. So the RTC clock is normal but the system clock is out of sync?

Hi @WayneWWW

It seems so. However I haven’t check RTC again. I always notice incorrect date and time on my ubuntu. This behavior is seen on all of my 3-4 Jetson devices.

So far I use NTP to sync the date and time but that was just a workaround. In actual environment, I don’t have internet connection to use NTP or so.

Anyways, can you please tell me the steps to debug the issue further?

Thanks a lot

Hi, the backup battery can not insist on so many days to keep time.

Hello @Trumany

Thanks a lot. Probably this is why I am seeing incorrect date and time on my all Jetson devices.

Is there any workaround to make the clock persistence at least for a month?

Thanks again

No other way than a big battery. Maybe you can use a battery with enough power capacity. The RTC part working current is about 2uA and voltage level is ~3V. You can calculate out backup battery feature based on that.

Hello @Trumany

Thank you very much. Can you please elaborate a bit more?

Are you suggesting to replace the super capacitor with a battery? Or something else? If so, can you please provide a circuit diagram?

Thank you again

As above. Just replace current cell on board, no other circuit design needed.

Hello @Trumany

Thank you very much. I will update you the status after implementing your suggestion.

Thanks again

Hello @Trumany and @WayneWWW

I turned on my jetson a while ago (April 19th) and executed the timedatectl command. I noticed that the RTC time is also changed. Therefore I decided to inform you to get a green signal to replace the supercapacitor. Please see the output of the command below:

$ timedatectl
                      Local time: Wed 2023-04-12 11:56:39 JST
                  Universal time: Wed 2023-04-12 02:56:39 UTC
                        RTC time: Sat 2000-01-01 01:07:49
                       Time zone: Asia/Tokyo (JST, +0900)
       System clock synchronized: no
systemd-timesyncd.service active: yes
                 RTC in local TZ: no

Please note that my aim is to retain the clock for at least a month (longer is preferred).

I am looking forward to hearing from you.


Do you enable the “backup-battery” by device tree?
Please reference below topic to enable the battery charging function.

Thank you very much, @ShaneCCC

I am using a recently flashed device (JetPack 4.6). I did not change any such system configuration.

Thank you for sharing it. I am looking into it.

Meanwhile, I noticed a surprising behavior with the supercapacitors. It is always 0 V (whether turned on or off). Please see attached picture below:

I am confused if it is a hardware issue or a software issue.

Sorry for the late response, have you managed to get issue resolved or still need the support? Thanks

The issue is being disucssed in another thread at Supercapacitor shows 0V even when powered on - #48 by Trumany

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.