Install of tensorflow following nvidia's doc fails?

Dear Nvidia’s team,

I just received my brand new Jetson Orin Nano and flashed the L4T 35.4.1 and Jetpack 5.1.2
Trying to install tensorflow, I follow the documentation as described here: Installing TensorFlow for Jetson Platform - NVIDIA Docs but end up with a version error.
Upon reaching this line of the documentation:

$ sudo pip3 install --extra-index-url tensorflow==2.12.0+nv23.04

I get this result:

$ sudo pip3 install --extra-index-url tensorflow==2.12.0+nv23.04
Looking in indexes:,
ERROR: Could not find a version that satisfies the requirement tensorflow==2.12.0+nv23.04 (from versions: 1.15.5+nv23.1, 1.15.5+nv23.2, 1.15.5+nv23.3, 2.10.0rc0, 2.10.0rc1, 2.10.0rc2, 2.10.0rc3, 2.10.0, 2.10.1, 2.11.0rc0, 2.11.0rc1, 2.11.0rc2, 2.11.0, 2.11.0+nv23.1, 2.11.0+nv23.2, 2.11.0+nv23.3, 2.11.1, 2.12.0rc0, 2.12.0rc1, 2.12.0, 2.12.1, 2.13.0rc0, 2.13.0rc1, 2.13.0rc2, 2.13.0)
ERROR: No matching distribution found for tensorflow==2.12.0+nv23.04

I also randomly tried with jp/512 or nv23.08 but get the same result.
Would you have any idea of the correct versions number I should use?
Should I change the nv version?

Here are some versioning descriptions:

$ sudo apt show nvidia-jetpack
Package: nvidia-jetpack
Version: 5.1.2-b104
Priority: standard
Section: metapackages
Maintainer: NVIDIA Corporation
Installed-Size: 199 kB
Depends: nvidia-jetpack-runtime (= 5.1.2-b104), nvidia-jetpack-dev (= 5.1.2-b104)
Download-Size: 29.3 kB
APT-Manual-Installed: yes
APT-Sources: r35.4/main arm64 Packages
Description: NVIDIA Jetpack Meta Package
$ ./
NVIDIA NVIDIA Orin Nano Developer Kit
 L4T 35.4.1 [ JetPack UNKNOWN ]
   Ubuntu 20.04.6 LTS
   Kernel Version: 5.10.120-tegra
 CUDA 11.4.315
   CUDA Architecture: 8.7
 OpenCV version: 4.5.4
   OpenCV Cuda: YES
 Vision Works: NOT_INSTALLED
 VPI: 2.3.9
 Vulcan: 1.3.204

Thank you very much for your esteemed help

Hi again,

For some reason, not knowing what to do with the NV VERSION, I retried to install without the +nv23.04 and yeay, it worked!
Succeeding with this install needed some guesswork, but it was done in the end.


For JetPack 5.1.2, please try the following command:

$ sudo pip3 install --extra-index-url tensorflow==2.12.0+nv23.06


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.