install scipy on jetson nano

Hi all,

I was trying to install scipy on the nano within a python3 virtual env but it failed…
Here is the steps i did:

sudo apt-get install git cmake
sudo apt-get install libatlas-base-dev gfortran
sudo apt-get install libhdf5-serial-dev hdf5-tools
sudo apt-get install python3-dev

then i just install tensorflow with the official link from NVIDIA and it worked but scipy i could not…

I got the following error for scipy installation:

Installing build dependencies ... done
Getting requirements to build wheel ... done
Preparing wheel metadata ... done
Building wheels for collected packages: scipy
WARNING: Building wheel for scipy failed: [Errno 13] Permission denied: '/home/enroutenano/.cache/pip/wheels/58'
Failed to build scipy
ERROR: Could not build wheels for scipy which use PEP 517 and cannot be installed directly

I also tried to

sudo apt-get update

But it failed, still the same result.
Please help.

Thank you in advance


It looks like an authority issue:

WARNING: Building wheel for scipy failed: [Errno 13] Permission denied: '/home/enroutenano/.cache/pip/wheels/58'

Could you check if you have the authority to access this node first?




I dont have that “58” folder. i only have wheels folder.

Here is the result of permission command on wheels folder:

(deep_learning) enroutenano@enroutenano-desktop:~/.cache/pip/wheels$ ll
total 12
drwxr-xr-x 3 root root 4096 6月 4 11:19 ./
drwxr-xr-x 3 root root 4096 6月 4 11:19 ../
drwxr-xr-x 3 root root 4096 6月 4 11:19 70/


Moreover, i could install numpy and tensorflow within the virtualenv, i dont understand why scipy doesnt work.

sudo pip install scipy

works but install it globally which i dont want to…

Thank you


I tried this:

sudo pip install scipy

but my platform is Jetson TX2 and it work well.

Good luck¡

I had the same issue when installing scipy into a virtualenv on my Nano. Not sure why it would be so for scipy specifically, but it relates to not being the owner (in your case) of /home/enroutenano/.cache/pip, hence the permission denied message. The fix was simple, at least it was on my Nano, try this hopefully it should solve the problem; sudo chown -R enroutenano /home/enroutenano/.cache/pip

Dose issue was fixed? @schoninger

I got same error and can’t fix.

Dear sir Henry Nguyen,

Yes i could fixed the error by installing scipy within my virtual env with root.

sudo su -

and then source your virtualenv and install scipy with

pip install scipy

Hope it helps


Yes I had the same setup issue, just forgot to invoke my su powers. Thank You for saving me endless hours re flashing

Hi all I’ve installed scipy using the command

sudo apt-get install python3-scipy

But when importing in python3.7 I get:

ImportError: cannot import name '_ccallback_c' from 'scipy._lib' (/usr/lib/python3/dist-packages/scipy/_lib/

Any clues? I’ve been trying to find a .whl for aarch64 but no luck



Do you have both python 3.6 and python 3.7 on your environment?

If yes, this error might be related to an incompatible version.
Would you mind to remove the scipy for python 3.6 first?