How to Install PyQt6 Jetson nano

How to install pyqt6 on python3.8 in jetson nano ??

I tried “sudo pip install pyqt6” . I got an error about sip

Building wheel for sip (pyproject.toml)did not run successfully
exit code: 1
[153 ines of output]
running bdist wheel
running build
running build py
creatingbuilcreatingbuild/lib.linux-aarch64-cpvthon-39creating build/lib .linuxaarch64-cpvthon-39/sipbuildcopying sipbuild/project.py-> build/lib.linux-aarch64-cpython-39/sipbuid

Hello,

I am moving your topic to the Jetson category for better visibility.

Hi,

Could you try the following:

$ pip install --upgrade pip
$ pip install sip

Thanks.

I have already installed the sip,still not work

Building wheels for collected packages: pyqt6-sip
Building wheel for pyqt6-sip (pyproject.toml) … error
error: subprocess-exited-with-error

× Building wheel for pyqt6-sip (pyproject.toml) did not run successfully.
│ exit code: 1
╰─> [12 lines of output]
running bdist_wheel
running build
running build_ext
building ‘PyQt6.sip’ extension
creating build
creating build/temp.linux-aarch64-cpython-39
aarch64-linux-gnu-gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -g -fwrapv -O2 -fPIC -I/usr/include/python3.9 -c sip_array.c -o build/temp.linux-aarch64-cpython-39/sip_array.o
sip_array.c:21:10: fatal error: Python.h: No such file or directory
21 | include <Python.h>
| ^~~~~~~~~~
compilation terminated.
error: command ‘/usr/bin/aarch64-linux-gnu-gcc’ failed with exit code 1
[end of output]

note: This error originates from a subprocess, and is likely not a problem with pip.
ERROR: Failed building wheel for pyqt6-sip
Failed to build pyqt6-sip
ERROR: Could not build wheels for pyqt6-sip, which is required to install pyproject.toml-based projects

Hi,

sip_array.c:21:10: fatal error: Python.h: No such file or directory

This indicates that there is no python-dev package in your environment.
Please install it and try it again.

$ sudo apt-get install python-dev python3-dev

Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.