Cross compiling PyQt6 v6.4.2 on NVIDIA Jetson Nano

Hello, what resources are there to get PyQt6 running on the Jetson Nano? When attempting to install PyQt6 on Python 3.7.9 I get the following error:

Defaulting to user installation because normal site-packages is not writeable
Collecting PyQt6==6.4.2
Using cached PyQt6-6.4.2.tar.gz (1.0 MB)
Installing build dependencies … done
Getting requirements to build wheel … done
Preparing metadata (pyproject.toml) … error
error: subprocess-exited-with-error

× Preparing metadata (pyproject.toml) did not run successfully.
│ exit code: 1
╰─> [17 lines of output]
Querying qmake about your Qt installation…
pyproject.toml: line 7: using ‘[tool.sip.metadata]’ to specify the project metadata is deprecated and will be removed in SIP v7.0.0, use ‘[project]’ instead
Traceback (most recent call last):
File “/home/team11/.local/lib/python3.7/site-packages/pip/_vendor/pyproject_hooks/_in_process/_in_process.py”, line 353, in
main()
File “/home/team11/.local/lib/python3.7/site-packages/pip/_vendor/pyproject_hooks/_in_process/_in_process.py”, line 335, in main
json_out[‘return_val’] = hook(**hook_input[‘kwargs’])
File “/home/team11/.local/lib/python3.7/site-packages/pip/_vendor/pyproject_hooks/_in_process/_in_process.py”, line 152, in prepare_metadata_for_build_wheel
whl_basename = backend.build_wheel(metadata_directory, config_settings)
File “/tmp/pip-build-env-6f00pipt/overlay/lib/python3.7/site-packages/sipbuild/api.py”, line 47, in build_wheel
arguments=_convert_config_settings(config_settings))
File “/tmp/pip-build-env-6f00pipt/overlay/lib/python3.7/site-packages/sipbuild/abstract_project.py”, line 92, in bootstrap
project.setup(pyproject, tool, tool_description)
File “/tmp/pip-build-env-6f00pipt/overlay/lib/python3.7/site-packages/sipbuild/project.py”, line 603, in setup
self.update(tool)
File “project.py”, line 164, in update
sipbuild.exceptions.UserException
[end of output]

note: This error originates from a subprocess, and is likely not a problem with pip.
error: metadata-generation-failed

× Encountered error while generating package metadata.
╰─> See above for output.

note: This is an issue with the package mentioned above, not pip.
hint: See above for details.

Attempts at diagnosing this issue with sites like: Ubuntu – Details of package qt6-base-dev in jammy

have not worked.

Hi,
This would need other users to share experience. There are topics about building QT on Jetson Nano:
PySide2 (Qt for python) installation on Jetson Xavier - #5 by Muscle_Oliver
Jetson Nano and Qt5 - #2 by WayneWWW
Pyqt not working on Nano - #4 by coolbot
How to Install PyQt5 Jetson nano - #2 by prince.alondra

There is no topics about cross compiling. Would see if any user have tried it and can share suggestion.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.