Pip3 issue

Hello we are really struggling to get packages from pypi installed using pip3 on our jetson nano. We have tried numpy, matpotlib and a few others its looks like the same problem

SystemError: Cannot compile ‘Python.h’. Perhaps you need to install python-dev|python-devel.


Failed building wheel for numpy

Any ideas much welcome :-)

Hi @Patrick_McMahon, have you tried installing the python3-dev package like below?

$ sudo apt-get install python3-dev

Hi @dusty_nv, I’ve encountered this error before it’s actually the pypy-dev package that needs to be installed.

$  sudo apt install pypy-dev

Hello Dusty thanks for getting back sorry if this is a simple mistake on my part but I followed your line and got the following error below. Your futher help is very welcome :-)

patrick2020@patrick-jetson:~$ sudo apt-get install python3-dev
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
python3-dev : Depends: python3 (= 3.6.5-3) but 3.6.7-1~18.04 is to be installed
E: Unable to correct problems, you have held broken packages.

Hello Mike thanks for this we still got the error using PIP3 but looking at the other reply it looks like we need to have the correct python version running, its a bit confusing for a newbie !

All the best Patrick

Hi,Patrick, I have met the same problem ,have u solve it?