Installed pip 3 but when I run pip -version wont run

I’m working with a jetson nano which had python2.6 and 3.6 preinstalled. I installed python3.7 through sudo apt install python3.7-dev

When I tried to run the pip command, it said there was no such command. So I installed pip and pip 3 through:

sudo apt update
sudo apt install python3-pip


 pip 9.0.1 from /usr/lib/python3/dist-packages (python 3.7)

So it worked fine. But pip3 and pip stopped working after I downloaded the python dependencies to install mxnet via:

sudo apt-get update
sudo apt-get install -y \
                        build-essential \
                        git \
                        libopenblas-dev \
                        libopencv-dev \
                        python3-pip \

sudo pip3 install --upgrade \
                        pip \
                        setuptools \

It says that ‘-bash: /usr/bin/pip3: No such file or directory’

I’m not really sure what went wrong. Even when I retry to install pip or pip3 the same error comes out.

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.


Would you mind checking if the /usr/bin/pip3 exist on your environment first?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.