Installing Soft-RoCE

Hello, I am trying to install Soft RoCE on a VM with ubuntu server 18.04 OS and my system does not have an RDMA enabled NIC.
I followed the steps in this documentation (ESPCommunity) but it gave me an error when I tried to make install the user space for not being able to find librdmacm.so.1.3.51.0 in build/lib directory.
I also checked and I found out that the developers do not support make/ninja installs and they recommend using other methods which I could not understand. (Re: install-step fails for pandoc-prebuilt man-pages in infiniband-diags/man - Leon Romanovsky)
Moreover, I tried installing rdma-core using apt install but rxe_cfg start did not work and printed rxe modules not loaded.
In addition, I found that rxe_cfg has been deprecated from 01/2020 (NFS over SoftRoCE setup - Linux NFS) so I tried installing iproute2 but when I tried to use rdma link add, even though it understood the rdma link command, it gave me an error saying there is no sub-command add for rdma link.

I have tried all this with and without removing Mellanox ConnectX HCA support, Mellanox 5th generation network adapters(ConnectX series) support and Mellanox HCA support when installing the linux kernel.

Thank you very much,
Best,
Arman