Intellisense in CUDA?

For some reason I can’t get intellisense to work with cuda .cu files…has anyone else?

What is intellisense?

I meant to post this under the XP section, but I am referring to Intellisense in Microsoft Visual Studio…for automatically listing members and showing parameter information in the editor

Oh, ok. Then I can not really help you I am afraid, but you can try to search the forums. There was a post in the beginning about how to add .cu files to vi, maybe they also posted the same for VS.

I already get it to recognize .cu files with CUDA syntax highlighting (and also got the CUDA custom build profile), but it’s just intellisense that isn’t working, oddly. Maybe a mod could move this into the windows section for me.

Has anyone found a fix for this?

I have the same problem (no intellisense in VC++ 2005 when viewing a ‘.cu’ file). Intellisense for me is by far the easiest way to view function overloads, variable types, etc. Coding without it is painful.

(Aside: Syntax highlighting is working fine.)

This thread seems to indicate a solution: http://forums.nvidia.com/index.php?showtop…hl=intellisense

I managed to solve the problem:

http://www.wizardsofeast.com/?p=378

Great! I have tried it and it works for me. If solution is so simple I think that NVIDIA, should document it where they explain how to activate syntax highlighting ,or even do the update in register key automatically, when CUDA toolkit is installed

It works fine and is ultra simple! specially useful to navigate through functions :thumbup:

I was (and still) using Visual Assist X, I met this app in another thread of the forum, it still can improve Highlighting and specially Intellisense a lot.

The steps I do to configure the Visual Assist X properly are the next ones (in Visual Studio 2008):

First, close all the instances of Visual Studio and install the software.

Second, find the Visual Assist X install directory: (X:\Program Files\Visual Assist X\AutoText\latest) and then make a copy of Cpp.tpl and rename it to Cu.tpl

Third, Open and close Visual Studio (this initializes Visual Assist X parameters by creating some folders/variables in the Registry ).

Fourth, open the regedit table and go to:

HKEY_CURRENT_USER\Software\Whole Tomato\Visual Assist X\VANet9

Finally add .cu; to the ExtSource key and add .cuh; to the ExtHeader key

I have Visual C++ 2008 Express Edition and I can’t find the path.
But I found this path:
HKEY_CURRENT_USER\Software\Microsoft\VCExpress\9.0\Languages\Language Services\C/C++
I’ve added .c and .cuh extensions to NCB Default C/C++
But somehow that doesn’t work :(

Oh I forgot to mention that I’ve installed CUDA toolkit and CUDA SDK 3.0
And I’m using Windows 7 32bit

add .cu and .cuh (also .cl if using opencl) , c is already in the key

okay… that works now! :D

thanks

okay… that works now! :D

thanks

I have done all the steps mentioned here to enable intellisense in *.cu files but it still doesn’t work. Any suggestions (I use VC2008EE)?