Is developer driver for ubuntu 11.10 (linux kernel 3.0.0) out? I need to install the developer drive

Hello, everyone

I have install ubuntu 11.10 on my computer and was trying to install the developer version of the nvidia driver. However, the latest developer driver is 270.41.19 on the official site.

I believe I have to install driver with patch higher than 280.0 on linux kernel 3.0.0, there is a default driver (280.13) come with the ubuntu 11.10 installation and it worked. If I try to install 270.41.19 patch, then I will have error log below:

ERROR: If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

   If you are using a Linux 2.6 kernel, please make sure
   you have configured kernel sources matching your kernel
   installed on your system. If you specified a separate
   output directory using either the "KBUILD_OUTPUT" or
   the "O" KBUILD parameter, make sure to specify this
   directory with the SYSOUT environment variable or with
   the equivalent nvidia-installer command line option.
   
   Depending on where and how the kernel sources (or the
   kernel headers) were installed, you may need to specify
   their location with the SYSSRC environment variable or
   the equivalent nvidia-installer command line option.

So when would the develop version driver for 280.13 patch come out? Is there anything I can do by myself to compile cuda codes on my machine?

Thanks!

If Ubuntu is shipping with that recent of a driver, then you don’t need the developer driver. The developer driver is usually just a beta release of the driver at the time the CUDA toolkit was released. As far as I know, there is nothing else special about the developer driver.

Thanks for your reply, but when I try to compile the SDK project deviceQueryDrv, I get error like

/usr/bin/ld: cannot find -lcuda

And when I try to compile the whole SDK, I get error like

rendercheck_gl.cpp:(.text+0xfbb): undefined reference to `gluErrorString’

That’s happend after I installed cuda toolkit, and I set the environment variable, I assume that’s because I have not installed the develop driver yet.

Any ideas?

I’m not sure why that library isn’t found. If the Ubuntu packaging has put it in a strange place, or left it out for some reason, you can go grab the latest NVIDIA driver package here:

http://www.nvidia.com/Download/index.aspx

and install it yourself. (As of right now, the latest driver is 280.13.)

This error means you are missing libglut (an OpenGL utility library unrelated to CUDA). You have to install it with the following command:

sudo apt-get install freeglut3-dev

for -lcuda:

in “NVIDIA_GPU_Computing_SDK/C/common/common.mk”

You can add “-L/usr/lib64/nvidia-current” :

for gluErrorString

Thanks for your reply, I simply runned the command

update-alternatives --install /usr/bin/g++ g++ /usr/bin/g+±4.4 10

provide by you, and then everything worked!

Thanks again!