IsaacGymEnv task run issue

I am currently using the following settings:
Driver Version : 525.116.04
CUDA: 11.8
torch: 1.8.1

when I try to run

python task=Ant

It returns the following error log:

Traceback (most recent call last):
  File "", line 194, in launch_rlg_hydra
    'sigma': cfg.sigma if cfg.sigma != '' else None
  File "/home/tc/anaconda3/envs/rlgpu/lib/python3.7/site-packages/rl_games/", line 121, in run
  File "/home/tc/anaconda3/envs/rlgpu/lib/python3.7/site-packages/rl_games/", line 102, in run_train
  File "/home/tc/anaconda3/envs/rlgpu/lib/python3.7/site-packages/rl_games/common/", line 1226, in train
    step_time, play_time, update_time, sum_time, a_losses, c_losses, b_losses, entropies, kls, last_lr, lr_mul = self.train_epoch()
  File "/home/tc/anaconda3/envs/rlgpu/lib/python3.7/site-packages/rl_games/common/", line 1090, in train_epoch
    batch_dict = self.play_steps()
  File "/home/tc/anaconda3/envs/rlgpu/lib/python3.7/site-packages/rl_games/common/", line 674, in play_steps
    self.obs, rewards, self.dones, infos = self.env_step(res_dict['actions'])
  File "/home/tc/anaconda3/envs/rlgpu/lib/python3.7/site-packages/rl_games/common/", line 495, in env_step
    obs, rewards, dones, infos = self.vec_env.step(actions)
  File "/home/tc/RL_Project/IsaacGymEnvs/isaacgymenvs/utils/", line 246, in step
    return  self.env.step(actions)
  File "/home/tc/RL_Project/IsaacGymEnvs/isaacgymenvs/tasks/base/", line 355, in step
  File "/home/tc/RL_Project/IsaacGymEnvs/isaacgymenvs/tasks/", line 288, in post_physics_step
  File "/home/tc/RL_Project/IsaacGymEnvs/isaacgymenvs/tasks/", line 252, in reset_idx
    positions = torch_rand_float(-0.2, 0.2, (len(env_ids), self.num_dof), device=self.device)
RuntimeError: The following operation failed in the TorchScript interpreter.
Traceback of TorchScript (most recent call last):
RuntimeError: nvrtc: error: invalid value for --gpu-architecture (-arch)

Can someone help me with this please?

I also tried using
Driver Version: 530.30.02
CUDA: 12.1
torch: 1.8.1

and got the same error. I am using RTX 4070.

I realized that torch 1.8.1 may not be able to work with CUDA 12.1 or 11.8, so I downgraded to CUDA 11.1 and cuDNN 8.0.5. But this error is still popping up. The driver version is 525.89.02.