Issue running Deepstream docker container

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
Nvidia Jetson ORIN AGX 32GB industrial module provided by Auvidea
• DeepStream Version
Deepstream SDK 6.1
• JetPack Version (valid for Jetson only)
Jetpack 5.0.2
• TensorRT Version
• Issue Type( questions, new requirements, bugs)
I built a custom Deepstream docker image for my application mainly inspired by This and saved it in our private container registry. I pulled the docker image and ran it on 2 different Jetsons( model specified above) using docker compose with the following docker-compose.yml configuration:

version: '3'
        command: "/deepstream-custom-app -c config_deepstream_app.txt -t"
        container_name: deepstream
            context: .
            dockerfile: docker/deepstream/Dockerfile.deepstream
            - deepstream_configuration_textfile.txt:/config_deepstream_app.txt
        restart: on-failure
            - "2000:2000"
            - rabbitmq #defined in actual yml file
        runtime: nvidia
                        - driver: nvidia
                          count: 1
                          capabilities: [gpu]

The 2 devices were flashed with the same way and contain the same components installed on the host system however on one of them the docker container exits with error 255: “gst_element_factory_make: no such element factory “nvstreammux”!”. There are other gst & nv plugins missing inside the container even though it was pulled from the docker container registry, and the same image worked as expected on the similar device.
The only way we could see the same behavior on the correct environment is when we ommitted --runtime=nvidia from the docker run command, and then we obtain the same error on both environments.
Forcing the value of docker default-runtime to “nvidia” does not solve the issue.
Looking for ideas on how to tackle this or potential issues.
NOTE: the Nvidia jetsons are operating in a remote environment and internet access is very limited.
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

Sorry for the long delay.

Due to hardware and driver limitations, some libraries on Jeton are shared between the host and Docker.

The dockerfile as you mentioned is used for ds-63.but you host is ds-6.1,I think this is problem.

You’d better update your device to the same version of the jetpack.

Hi and thank you for your reply.

Actually I tagged my deepstream docker image as ‘latest’, but it was built using deepstream 6.1.1. I followed the link I pasted in the original post but in my Dockerfile I copy the DS6.1.1_sdk.tar file and use it to build docker inside the image. therefore I am certain that both systems have Jetpack 5.0.2 and that the docker images have versions 6.1.1.

Any idea what else could be an issue?

If you can make sure jetpack and ds are installed normally.
try in /opt/nvidia/deepstream/deepstream, just clear gstreamer cache.

Hi again @junshengy
I doublechecked the deepstream installation inside the container by checking the paths and files defined inside the script are existing. They do. ‘deepstream-app’ and the others are installed.
As I specified previously I don’t install deepstream on the host system only with Docker.
Attached is the Dockerfile I used to build the docker image I use on all my devices.
I also want to point out that this docker image version is deployed on 3 other Nvidia Jetsons AGX and only one is displaying this behavior
Dockerfile.txt (5.6 KB)