Issues recognizing brand new GTX 2070


Bug report:

I’ve recently purchased a GTX 2070 and am struggling to get it recognized by my system. The seller recommended I post here before requesting a return.

I am running Ubuntu 16.04 and have reinstalled the CUDA drivers. Earlier today, I had two 970s in the system and they were both working fine and recognized. I’ve now removed them both, and tried moving the 2070 to both slots, but still nothing. My motherboard is Gigabyte GA-Z170X-UD3 which I believe supports the 2070.

I’d love to know if there’s ways to troubleshoot whether it’s a hardware issue or a software issue.

Here’s some outputs of commands:

~$ nvidia-smi
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
~$ dkms status
bbswitch, 0.8, 4.15.0-74-generic, x86_64: installed
nvidia, 430.64: added
nvidia-440, 440.33.01, 4.15.0-74-generic, x86_64: installed
virtualbox, 5.1.38, 4.15.0-58-generic, x86_64: installed
virtualbox, 5.1.38, 4.15.0-74-generic, x86_64: installed
virtualbox, 5.1.38, 4.4.0-171-generic, x86_64: installed
~$ dmesg | grep NVRM
~$ lspci | grep -i nvidia
~$ lsmod | grep nvidia
~$ lsmod | grep nouveau

(No output for the above commands.)

~$ dpkg -l | grep nvidia
ii  nvidia-440                                                  440.33.01-0ubuntu1                                                  amd64        NVIDIA binary driver - version 440.33.01
ii  nvidia-440-dev                                              440.33.01-0ubuntu1                                                  amd64        NVIDIA binary Xorg driver development files
ii  nvidia-modprobe                                             440.33.01-0ubuntu1                                                  amd64        Load the NVIDIA kernel driver and create device files
ii  nvidia-opencl-icd-440                                       440.33.01-0ubuntu1                                                  amd64        NVIDIA OpenCL ICD
ii  nvidia-prime                                                0.8.2                                                               amd64        Tools to enable NVIDIA's Prime
ii  nvidia-settings                                             440.33.01-0ubuntu1                                                  amd64        Tool for configuring the NVIDIA graphics driver
~$ sudo lshw -C display
  *-display UNCLAIMED
       description: VGA compatible controller
       product: HD Graphics 530
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:de000000-deffffff memory:c0000000-cfffffff ioport:f000(size=64) memory:c0000-dffff



lspci | grep -i vga

gives your just your Intel HD graphics then your GPU is not detected by your motherboard/doesn’t really work/isn’t properly enabled.

Try updating BIOS to the latest version. If that doesn’t help, this GPU is dead/faulty.

Thanks for the feedback, @birdie. I’ll try updating the BIOS and see what happens.

Holy cow what a simple fix - that worked! Updated the BIOS and now the GPU shows up just fine.

Thanks @birdie! Wish I’d posted here 4 hours ago…