Issues with NVIDA DLI - Fundamentals of Accelerated Computing with Cuda Python

Hi,

For about a week I have been trying to complete the - Custom Kernels and Memory Management for Cuda Python with Numba. Every time I want to ‘Asses Task’ an Error pops up. It tells me to try again later. I have been trying for a week now and still get the same error. Is there any fix to this? The same is happening for the next section - Multidiemnsional Grids and Shared Memory.

The assess task section is a test. You have to complete the test successfully, otherwise you will receive an error.

If you believe you have done the test correctly, I suggest you use the “Contact Us” link at the bottom of the dli webpage where you enroll for the course. For example, use the “Contact Us” link at the bottom of this page

Yes I am sure I had it correct because it ran without a problem on the Jupyter notebook . I tried the contact us but they told me to post it in a forum . I also tried using different computers and internet providers ( phone hotspot) and still nothing. The other course that I’m taking - Intro to Deep Learning, works fine.

If they told you to post it on a forum it means that the code you have tried is incorrect. This thread may be of interest. A common problem when people are working in the jupyter notebook associated with that lab is that the notebook has a history, and remembers all imports previously done. This can make things appear to work in the notebook but fail when you get to the assessment. The assessment must work in a python environment with no previous imports done. I don’t know if that applies to your case or not, its just a suggestion.