Issues with Point Grey camera and USB ports?

So my team and I recently bought the Jetson TX1 developer kit and a Point Grey Blackfly (BFLY-U3-23S6C-C) and have some issues with the images coming in from the camera.

Setup:
Jetson TX1 developer kit with rel24.1
The Blackfly camera with USB3.0 connection, 16Mb buffer.
FlyCapture2 SDK for ARM
OpenCV4Tegra
Installed all dependencies for the FlyCapture2 SDK.

Running a sample code on my Ubuntu 14.04 laptop the camera runs fine on a USB3.0 port, no issues.
But when using the same code and libraries on the TX1 first the images come in fine from the buffer and after a short while the image splits in the middle and switch places.

Has anyone else come upon this issue?

Tests that have been done:
-Flashing the jetson without OpenCV4Tegra and compiling OpenCV 2.4.13 from source, same issue
-Tried the micro-USB port, here we had a longer time before the image splits.
-Saved the raw images and it appears the issue appears before any converting.

Point Grey says that we need to add the line usbcore.usbfs_memory_mb=1000 to /boot/extlinux/extlinux.conf which we have done first to get the images. Otherwise it didn’t work at all.

The sample code we tried:

We are thinking that it might have to do with buffering of the usb ports.

Does dmesg show anything while using USB during functional moments, and does anything else get logged after the error shows up?

linuxdev: Nothing out of the ordinary shows up in dmesg during functional moment, and nothing new in dmesg when the error in the image shows up.

Contacted Point Grey technical support, they wanted information from these commands at least:
lsusb -v
lspci
uname -a
lsb_release -a

So let’s see what they will reply with.

R24.2 did just come out with several fixes, you may want to try that as well. If you need to back up your current setup for later restore, you can clone then use the flash.sh “-r” option with reuse for restore. General information here (most of TK1 information applies to TX1);
http://elinux.org/Jetson/Cloning

JTX1 specific information on cloning:
https://devtalk.nvidia.com/default/topic/898999/jetson-tx1/tx1-r23-1-new-flash-structure-how-to-clone-/post/4784149/#4784149