It's Ultrawide 21:9 and higher hz supported?

I have a problem that happens randomly
I have the xiaomi mi monitor
It detects it most of the time 4096x2160 24hz maximum resolution or 3840x2160 60hz
Instead of its native resolution 3440x1440 100hz for HDMI 2.0

with Display port detected corrected native resolution for this version can up to 3440x1440p 120hz.

Is it a driver bug/limitation?
Sometimes I find the resolution 2560x1440p @60hz under HDMI however it allows me 1080p 120hz

On the other hand, in display port it seems to me 2560x1080 @ 144hz but not 2560x1440p

It also enables me some non-real resolutions that it puts next to (scaled)

I can’t tell you what the actual limits are. However, all modes are determined through EDID query of the monitor itself, and then the driver can be told to log why it accepts or rejects modes. I suggest you edit “/etc/X11/xorg.conf”, and edit the section “Device” to add “ModeDebug”:

Section "Device"
   Option "ModeDebug"

Boot once, and then attach a copy of “/var/log/Xorg.0.log” to the forum. That log will mention each mode and whether it is valid or invalid, along with the final mode pool.

Ok thanks ModeDebug it’s very useful to the log I have been found
If I use a capture card This interacts with EDID Capture info and nvidia tries to read this EDID so seems it’s a capture EDID limitation the edid capture force to 4K UHD.

So problem solved, I’ll have to force the edid through a custom edid and load the resolutions from there.

Xorg.0.log (1.1 MB)

Yes, a similar issue often comes along when someone uses a VGA adapter which does not have EDID (or for those who point out that some have an EDID, this EDID is an incompatible protocol despite being technically compatible).

Solved it Force edid to Screen instead edid by omition .

Although you have to tinker to support certain resolutions :P

Sometimes will be unstable for some reason and said Failed to move MetaMode NULL Dpy-0 and some consistences by Nvidia-settings

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.