[JetPack 3.2.1] DSI ouput 4k abnormal

Hi All,

I have added a chip to convert dsi to hdmi.

JetsonTX2 DSI --> DSI2HDMI --> HDMI Monitor

output 1080p is normal, but output 4k is abnormal.

using test generator patten, the DSI2HDMI chip output 4k is normal.

here is my dts configure:

		panel-dsi2hdmi-lt9611 {
			status = "disabled";
			compatible = "f,lt9611";
			nvidia,dsi-instance = <DSI_INSTANCE_0>;
			nvidia,dsi-n-data-lanes = <4>;
			nvidia,dsi-pixel-format = <TEGRA_DSI_PIXEL_FORMAT_24BIT_P>;
			nvidia,dsi-refresh-rate = <60>;
			nvidia,dsi-video-data-type = <TEGRA_DSI_VIDEO_TYPE_VIDEO_MODE>;
			nvidia,dsi-video-clock-mode = <TEGRA_DSI_VIDEO_CLOCK_CONTINUOUS>;
			nvidia,dsi-video-burst-mode = <TEGRA_DSI_VIDEO_NONE_BURST_MODE_WITH_SYNC_END>;
			nvidia,dsi-controller-vs = <DSI_VS_1>;
			nvidia,dsi-virtual-channel = <TEGRA_DSI_VIRTUAL_CHANNEL_0>;
			nvidia,dsi-panel-reset = <TEGRA_DSI_DISABLE>;
			nvidia,dsi-ulpm-not-support = <TEGRA_DSI_ENABLE>;
			nvidia,dsi-suspend-stop-stream-late = <TEGRA_DSI_DISABLE>;
			nvidia,dsi-power-saving-suspend = <TEGRA_DSI_DISABLE>;
			nvidia,default_color_space = <1>;	 /*default color profile:adobeRGB*/
			nvidia,en-vmm-vpp-with-i2c-config;
			disp-default-out {
				nvidia,out-type = <TEGRA_DC_OUT_DSI>;
				nvidia,out-flags = <TEGRA_DC_OUT_CONTINUOUS_MODE>;
				nvidia,out-parent-clk = "pll_d";
				nvidia,out-xres = <3840>;
				nvidia,out-yres = <2160>;
			};
			display-timings {
				3840x2160-32 {
					clock-frequency = <297000000>;
					hactive = <3840>;
					vactive = <2160>;
					hfront-porch = <176>;
					hback-porch = <296>;
					hsync-len = <88>;
					vfront-porch = <8>;
					vback-porch = <72>;
					vsync-len = <10>;
					nvidia,h-ref-to-sync = <1>;
					nvidia,v-ref-to-sync = <7>;
				};
                           };
                    };

Kindly help me resolve this issue.
With regards,
Thank you.

Hi,

Please dump the dmesg and also the clk information

sudo -s
cd /sys/kernel/debug/
cat clk/clk_summary
cat tegradc.0/mode
cd /sys/class/graphics/fb0/mode

Does this HDMI monitor support 4k@60 mode?

Hi WayneWWW:
This HDMI monitor support 4k@30 mode.

I have changed the refresh rate in dts:
//nvidia,dsi-refresh-rate = <60>;
nvidia,dsi-refresh-rate = <30>;

the output still abnormal.

root@localhost:/sys/kernel/debug# cat tegradc.0/mode
pclk: 297000000
h_ref_to_sync: 1
v_ref_to_sync: 7
h_sync_width: 88
v_sync_width: 10
h_back_porch: 296
v_back_porch: 72
h_active: 3840
v_active: 2160
h_front_porch: 176
v_front_porch: 8
flags: 0x0
stereo_mode: 0
avi_m: 0x0
vmode: 0x0

root@localhost:/sys/kernel/debug# cat /sys/class/graphics/fb0/mode
U:3840x2160p-30

cat clk/clk_summary:
clk_summary.log (34.0 KB)

thanks for reply.

Hi XavierSu,

I don’t see any error in the clk side. Could you make sure your monitor could support the exact same mode? Please note that it is not just 4k@30. I mean all the parameters in #5 need to support on your monitor.

Hi, @WayneWWW
I have tested several resolution,I don’t think the monitor not support the parameters.

output normal:
1920x1080@30
1920x1080@60
1280x1024@60
1024x768@60

no output:
1280x720@60

output abnormal:
3840x1080@60
3840x2160@30

Any clue please tell me

Thanks!

Hi XavierSu,

I would say then we cannot share much help here.

It is not possible to enable a mode that is not fully supported on a HDMI monitor. If it can, why should I buy a 4k monitor? I could just buy a 1080p monitor and ask the source to dump 4k resolution. This is just same as what you are trying to do.

When you output some display modes to a monitor that doesn’t support such modes, there would possibly has noise and even distortion.

Hi @WayneWWW:
I do some test to the monitor:
Using HDMI port, output 4k@60 and 4k@30, the monitor is normal display.
Using DSI2HDMI port, output the color bar by enable the test patten generator of DSI2HDMI chip, the monitor is normal display.

So I think the monitor support what I need.

Then I focus on DSI2HDMI chip, I found some requirments for DSI source:
20200515114444

requirment a/b/c/d/e have been configured in TX2 dts.

20200515114855
I don’t know if f/g are configured correctly.

Thanks for reply!

Hi XavierSu,

I just confirmed f/g are already set as you want by default.