JetPack 5.0 DP:Error encoding with omxh264enc or nvv4l2h264enc in gstreamer

omxh264enc plugin cannot find in JetPack 5.0 DP .
nvv4l2h264enc plugin cannot work .
"appsrc name=imagesrc do-timestamp=true min-latency=0 max-latency=0 max-bytes=1000 is-live=true ! videoconvert !video/x-raw(memory:NVMM), format=(string)NV12,framerate=10/1,width=640,height=480 ! nvv4l2h264enc ! rtph264pay name=pay0 config-interval=1 pt=96 "

Hi,
The omx plugins are deprecated. Please use nvv4l2h264enc and try this string:

"appsrc name=imagesrc do-timestamp=true min-latency=0 max-latency=0 max-bytes=1000 is-live=true ! videoconvert ! video/x-raw, format=(string)NV12,framerate=10/1,width=640,height=480 ! nvvidconv ! video/x-raw(memory:NVMM) ! nvv4l2h264enc ! h264parse ! rtph264pay name=pay0 config-interval=1 pt=96 "
1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.