JetPack 5.1.2/L4T 35.4.1 is now live

JetPack 5.1.2 , the latest production release for Jetson is now live! JetPack 5.1.2 adds support for Jetson AGX Orin Industrial module and brings new features in bootloader, camera, security and OTA. JetPack 5.1.2 includes the same version of compute stack as JetPack 5.1.1 but upgrades VPI to VPI 2.3. JetPack 5.1.2 supports all Jetson Xavier and Orin modules and developer kits.

JetPack 5.1.2 includes Jetson Linux 35.4.1 with following highlights:

(Please read Jetson Linux Release notes for more details and list of known issues)

Please note that, we had deprecated Nvbuf_utils in JetPack 5 last year and with this release, we are removing Nvbuf_utils. Refer to migration guide to migrate from Nvbuf_utils to NvUtils.

Installing JetPack 5.1.2

You can install JetPack 5.1.2 using multiple ways:

  1. Using SDK Manager: Install JetPack 5.1.2 using SDK Manager on any Jetson Orin and Xavier modules.
  2. SDCard Image: If you are using Jetson Orin Nano Developer Kit or Jetson Xavier NX Developer kit, then you can use the SDCard image from JetPack 5.1.2 page.
  3. Flashing Scripts: Download the Jetson Linux tar balls from Jetson Linux 35.4.1 page and use flashing scripts to flash. Refer to QuickStart section in Jetson Linux Developer Guide.
  4. Debian Packages: After flashing Jetson Linux, you can install the rest of the JetPack using apt commands. Please refer JetPack documentation

To upgrade from a previous version of JetPack 5 using debian packages, refer to JetPack documentation.

JetPack 5.1.2 Components

  • Jetson Linux 35.3.1
  • CUDA 11.4.19
  • TensorRT 8.5.2
  • cuDNN 8.6.0
  • VPI 2.3
  • OpenCV 4.5.4
  • Vulkan 1.3
  • Nsight Systems 2022.5
  • Nsight Graphics 2022.6
  • Nsight DLD/Compute 2022.2

Resources

1 Like

It would be quite nice to update the documentation on Getting Started with Jetson AGX Orin Developer Kit | NVIDIA Developer. because this still refers to r34.1 which isn’t available anymore since last year :(

1 Like

Hi.
I just have installed jetpack 5.12 and for beginning tried to recompile and flash kernel to my Jetson AGX Orin 64GB-DRAM develop kit.
After flashing board never come up.
Can I get help?

Here is my procedure:

  1. Download toolchain from https://developer.nvidia.com/embedded/jetson-linux/bootlin-toolchain-gcc-93
    extract and set environment (according to Welcome — Jetson Linux Developer Guide documentation )
  2. Run the following commands to export the environment variables:
    export KERNEL_DIR=kernel-5.10
    export CROSS_COMPILE=$HOME/l4t-gcc/bin/aarch64-buildroot-linux-gnu-
    export JETPACK=$HOME/nvidia/nvidia_sdk/JetPack_5.1.2_Linux_JETSON_AGX_ORIN_TARGETS/Linux_for_Tegra
    export KERNEL_OUT=$JETPACK/images
    export KERNEL_MODULES_OUT=$JETPACK/images/modules
  3. Download BSP sources from the Jetson Download Center for NVIDIA Jetson Linux 35.4.1 and extract the sources into Jetpack directory:
    mkdir -p sources && cd sources
    tar -xvf public_sources.tbz2 Linux_for_Tegra/source/public/kernel_src.tbz2 --strip-components=3
    tar -xvf kernel_src.tbz2
  4. steps of building the BSP sources to generate the kernel Image, the external modules, and the device tree blob.
    4.1 Create the directories for the build outputs:
    mkdir -p $KERNEL_MODULES_OUT
    4.2 Clean the environment: ( install before: sudo apt-get install python3-sphinx )
    cd $JETPACK/sources/kernel/$KERNEL_DIR
    make mrproper
    4.3 Setup the default configuration:
    make ARCH=arm64 O=$KERNEL_OUT tegra_defconfig
    4.4 Build the BSP: ( install before: sudo apt-get install libssl-dev )
    make ARCH=arm64 O=$KERNEL_OUT CROSS_COMPILE=$CROSS_COMPILE -j4
    4.5. Install the modules to the output directory created in step 1:
    make modules_install ARCH=arm64 O=$KERNEL_OUT CROSS_COMPILE=$CROSS_COMPILE INSTALL_MOD_PATH=$KERNEL_MODULES_OUT
    4.6. Backup the binaries that come installed by default in Jetpack:
    BKUP_DATE=date "+%Y_%m_%d_%H_%M_%S"
    mv $JETPACK/kernel/Image{,.$BKUP_DATE}
    mv $JETPACK/kernel/kernel_supplements.tbz2{,.$BKUP_DATE}
    mv $JETPACK/kernel/dtb{,.$BKUP_DATE}
    4.7. Copy the binaries built to the default locations expected by the flashing tool:
    cd $KERNEL_OUT
    cp ./arch/arm64/boot/Image $JETPACK/kernel/
    cp -r ./arch/arm64/boot/dts/nvidia $JETPACK/kernel/dtb
    4.8. Update the kernel modules in the kernel supplements tarball:
    cd $KERNEL_MODULES_OUT
    tar --owner root --group root -cjf $JETPACK/kernel/kernel_supplements.tbz2 lib/modules
    4.9. Install tegra binaries:
    cd $JETPACK
    sudo ./apply_binaries.sh
  5. Set target to recovery mode and Execute the flash script:
    ./flash.sh jetson-agx-orin-devkit mmcblk0p1

After success in all steps, after reset I tried to run
sudo screen /dev/ttyACM0 115200
failed - /dev/ttyACM0 not found
Target is not running with display, keyboard and mouse connected.

Hey,

I had the same issue, i recommand you to use the shell script nv_build.sh to compile the kernel

I followed these steps

sudo apt update
sudo apt dist-upgrade
sudo reboot
sudo apt install nvidia-jetpack

but only got 35.2.1

How do I actually update? The SDK Manager deb package and docker container won’t actually run on the Jetson due to arm incompatibility.