JetPack 5.1.2/L4T 35.4.1 is now live

JetPack 5.1.2 , the latest production release for Jetson is now live! JetPack 5.1.2 adds support for Jetson AGX Orin Industrial module and brings new features in bootloader, camera, security and OTA. JetPack 5.1.2 includes the same version of compute stack as JetPack 5.1.1 but upgrades VPI to VPI 2.3. JetPack 5.1.2 supports all Jetson Xavier and Orin modules and developer kits.

JetPack 5.1.2 includes Jetson Linux 35.4.1 with following highlights:

(Please read Jetson Linux Release notes for more details and list of known issues)

Please note that, we had deprecated Nvbuf_utils in JetPack 5 last year and with this release, we are removing Nvbuf_utils. Refer to migration guide to migrate from Nvbuf_utils to NvUtils.

Installing JetPack 5.1.2

You can install JetPack 5.1.2 using multiple ways:

  1. Using SDK Manager: Install JetPack 5.1.2 using SDK Manager on any Jetson Orin and Xavier modules.
  2. SDCard Image: If you are using Jetson Orin Nano Developer Kit or Jetson Xavier NX Developer kit, then you can use the SDCard image from JetPack 5.1.2 page.
  3. Flashing Scripts: Download the Jetson Linux tar balls from Jetson Linux 35.4.1 page and use flashing scripts to flash. Refer to QuickStart section in Jetson Linux Developer Guide.
  4. Debian Packages: After flashing Jetson Linux, you can install the rest of the JetPack using apt commands. Please refer JetPack documentation

To upgrade from a previous version of JetPack 5 using debian packages, refer to JetPack documentation.

JetPack 5.1.2 Components

  • Jetson Linux 35.3.1
  • CUDA 11.4.19
  • TensorRT 8.5.2
  • cuDNN 8.6.0
  • VPI 2.3
  • OpenCV 4.5.4
  • Vulkan 1.3
  • Nsight Systems 2022.5
  • Nsight Graphics 2022.6
  • Nsight DLD/Compute 2022.2


I just tried the debian based update procedure on my Jetson Xavier NX and there seems to be an issue. After following the steps described in the document and doing the power cycle, the UEFI bios starts up, shows an upgrade progress bar, which gets to 11% and then stops, seems to reboot to the normal UEFI bios startup screen, which then boots into Ubuntu. But when it gets there I get a GUI that tells me that in order to complete the update process, I have to reboot.
When I do this I again get the UEFI update screen, which gets to 11% etc.
This seems to loop around forever, so I assume that there is an issue with the UEFI update side of things.
Does anybody have any information how to complete the upgrade process to Jetpack 5.1.2 successfully.

This is on a Jetson Xavier NX dev kit with the system booting from an NVME SSD, not the SD card.

I previously installed Jetpack 5.1.1 via SDK Manager, but I was loath to follow this route again as it should also update via the Debian route.

PS: The date for the used UEFI bios on the UEFI bios screen shows a march date. I assume that this means that it is still running the old UEFI bios, not the new one.

Does this latest release (5.1.2) address the PCIE Endpoint Mode configuration patches with having to manually change files or is it automatically taken into account like the 4.X releases?

More simply, do we have to apply the same patches as previous 5.X releases?

See this thread for reference:

Thank you!

Update: Just tried to do the update using SDK Manager and now I have a different issue: The installation seems to ignore the size of my SSD (250GB) and install itself in a 14 GB root partition, closely followed by some system level partitions and then a 235ish GB unused space section. This then leads to issues with installing the additional packages. Nothing that I do in SDK manager seems to change this behavior (its the latest available version). I can’t remember having this issue with the 5.1.1 install that I also had to do with SDK Manager (after the debian install messed up the update from 5.0 to 5.1.1, if I remember correctly).

Does anybody know how we can get SDK Manager to use the full capacity of the SSD?

Update 2: Just to check that I’m not crazy, I just reinstalled Jetpack 5.1.1 on the Jetson Xavier NX devkit and that one does fully utilize the SSD’s capacity. So there seems to be an issue in the Jetpack 5.1.2 scripts used by the SDK Manager that causes this underutilization of capacity.

Hopefully NVIDIA will patch this in the near future.

Update 3: if I now use the debian based update procedure, I’m back again to my original problem (of infinite UEFI update attempts that fail at 11%)

Hi @pieterjan.kuyten,

This is the announcement topic, please open up a seperate topic for your issue at below Xavier NX forum .
Latest Jetson & Embedded Systems/Jetson Xavier NX topics - NVIDIA Developer Forums

By further investigating, the root cause is that the layout used to flash external device is changed to “flash_l4t_t194_nvme.xml” from “flash_l4t_external.xml” in “” for T194 device.

This only affects the customer who is using SDKM to flash device on T194 device. For customers who use initrd flash to flash device, there is no effect.

For the customers who want to extend the size of APP partition on external device for T194 device, here is the workaround:

  1. Flashed the device. If customer has flashed device before, skip this step.
  2. Find the “” under “~/nvidia/nvidia_sdk//Linux_for_Tegra/” and replace the “flash_l4t_t194_nvme.xml” with “flash_l4t_external.xml”
  3. Re-flash the device