Jetpack 5.0.2 with Jetson Linux 35.1 is now live!

We are very pleased to announce that JetPack 5.0.2 is now released!

JetPack 5.0.2 production release replaces JetPack 5.0/5.0.1 Developer preview release which were for development purposes only. JetPack 5.0.2 is the first production release for Jetson AGX Orin. JetPack 5.0.2 includes Jetson Linux 35.1 BSP with Linux Kernel 5.10, an Ubuntu 20.04 based root file system, a UEFI based bootloader, and OP-TEE as Trusted Execution Environment. JetPack 5.0.2 includes the latest compute stack on Jetson with CUDA 11.4, TensorRT 8.4.1, cuDNN 8.4.1

This release supports Jetson AGX Orin 32 GB production module and Jetson AGX Orin Developer Kit. It also supports Jetson AGX Xavier series and Jetson Xavier NX series modules, as well as Jetson AGX Xavier Developer Kit and Jetson Xavier NX Developer Kit.

Note: Starting with this release, SDK Manager offers the option of either a full installation of JetPack or the installation of JetPack runtime components only. The JetPack runtime installation does not include samples or documentation and takes only half the storage as a full JetPack installation. Select full JetPack installation or JetPack runtime only installation from the drop down menu while selecting JetPack version.

Note: From JetPack 5.0.2 onwards, NVIDIA also hosts runtime and development debian meta packages for all JetPack components. The runtime packages do not include samples and documentations while the development packages include these and are intended for development. Users can install full JetPack or only runtime JetPack meta packages over Jetson Linux.

Note: Jetson Linux Sources are now available on GIT in addition to the Jetson Linux page. Refer to section “Downloading Jetson Linux Sources” in release notes for detail.

Below are the top highlights for JetPack 5.0.2. Please refer to JetPack 5.0.2 page for full lists of features:

  • Adds support for Jetson AGX Orin 32GB production module
  • Enables Jetson AGX Orin Developer Kit to emulate performance of Jetson AGX Orin 64GB, Jetson AGX Orin 32GB, Jetson Orin NX 16GB and Jetson Orin NX 8GB modules. Refer to the emulation section in release notes for detail.
  • Security
    • Secure storage in OP-TEE using normal world (REE) file system
  • Over The Air Updates:
    • Image Based OTA tools to upgrade Jetson AGX Xavier or Jetson Xavier NX modules running JetPack 4.x releases
  • Power:
    • Support for Power Estimator for Jetson AGX Orin and Jetson Xavier NX series
  • Camera:
    • Argus support for YUV444 and Linear RGB888 output format for Jetson AGX Xavier and Jetson Xavier NX.
    • HDR Support for Jetson AGX Orin. Digital Overlap (DOL) Mode and Piecewise Linear (PWL) are supported.
  • Multimedia:
    • AV1 encoding/decoding on Jetson AGX Orin
    • Support for nvJPEG load balancing to use 2 nvJPEG engines in Jetson AGX Orin, providing 2X the encoding\decoding performance compared to JetPack 5.0/5.0.1 Developer Preview releases.
    • Pre-Processing Enhancements (PPE) module. This module provides a framework for various video encode enhancement algorithms. Currently in this release Temporal Adaptive Quantization (TAQ) is supported.
  • Cloud Native:
    • New Containers on NGC:
      • JetPack container with all JetPack components like CUDA, cuDNN, TensorRT, VPI, etc within the container.
      • Cross Compilation Container which makes it simpler to cross compile JetPack and Jetson Linux components on a x86 host machine running Linux.
      • Jetson Linux Flashing Container which includes all the prerequisites required to flash Jetson modules and developer kits from a x86 host machine running Linux.

JetPack 5.0.2 Components:

  • Jetson Linux 35.1
  • CUDA 11.4.14
  • TensorRT 8.4.1
  • cuDNN 8.4.1
  • VPI 2.1
  • OpenCV 4.5.4
  • Vulkan 1.3
  • Nsight Systems 2022.3
  • Nsight Graphics 2022.3
  • Nsight Deep Learning Designer 2022.1

To upgrade from JetPack 5.0/5.0.1 Developer Preview:

First edit etc/apt/sources.list.d/nvidia-l4t-apt-source.list to first point to 35.1 repo (just change the version to r35.1 in both lines) and then use the following commands, then physcially reboot the system:

sudo apt update

sudo apt dist-upgrade

sudo apt install --fix-broken -o Dpkg::Options::="--force-overwrite"

The last line is required because in JetPack 5.0.2 release cuda-nvprof-11-4 package was renamed.

Jetson Xavier NX SD Card Image

If you have not previously run a JetPack 5.x release on your Jetson Xavier NX Developer kit, you must first update its QSPI before using this JetPack 5.0.2 SD Card image. You can download an updated QSPI image from JetPack 5.0.2 page, and then follow the QSPI update instructions from the Jetson Linux Developer Guide.

Resources:

I had expected an R34.x version. Did it get bumped to R35.x?

Yep it did, to R35.1.1

Hi,

I tried to follow the upgrade procedure, but it didn’t work for me. Two times I started from JP 5.0.1 and used the commands

sudo apt update
sudo apt dist-upgrade
sudo apt install --fix-broken -o Dpkg::Options::="--force-overwrite"

Both times I got questions about modified files (/etc/apt/sources.list.d/nvidia-l4t-apt-source.list, /etc/X11/xorg.conf) and both times I answered with ‘N’ (no). For nvidia-l4t-apt-source.list the change is interesting:

--- /etc/apt/sources.list.d/nvidia-l4t-apt-source.list  2022-08-17 14:30:43.199655047 +0200
+++ /etc/apt/sources.list.d/nvidia-l4t-apt-source.list.dpkg-new 2022-08-11 05:37:28.000000000 +0200
@@ -9,4 +9,4 @@
 # its affiliates is strictly prohibited.
 
 deb https://repo.download.nvidia.com/jetson/common r35.1 main
-deb https://repo.download.nvidia.com/jetson/t194 r35.1 main
+deb https://repo.download.nvidia.com/jetson/<SOC> r35.1 main

What does mean here?

The bootloader and kernel were not upgraded - after reboot I only got the serial console, no ethernet and usb network, no monitor output etc.

The relevant lines of the log are:

Setting up nvidia-l4t-bootloader (35.1.0-20220810203728) ...
83668-301---1--jetson-xavier-nx-devkit-qspi-
Starting bootloader post-install procedure.
ERROR. Procedure for bl_only_payload update FAILED.
Cannot install package. Exiting...
dpkg: error processing package nvidia-l4t-bootloader (--configure):
 installed nvidia-l4t-bootloader package post-installation script subprocess returned error exit status 1

and

Setting up nvidia-l4t-kernel (5.10.104-tegra-35.1.0-20220810203728) ...
Using the existing boot entry 'primary'
3668-301---1--jetson-xavier-nx-devkit-qspi-
Starting kernel post-install procedure.
ERROR. Procedure for kernel update FAILED.
Cannot install package. Exiting...
dpkg: error processing package nvidia-l4t-kernel (--configure):
 installed nvidia-l4t-kernel package post-installation script subprocess returned error exit status 1

Board: Seeed A206 with Jetson Xavier NX 8GB RAM+eMMC
Boot device: NVMe

I also tried to install via sdkmanager, but only the installation of 5.0.2 to eMMC succeeded. Using NVMe as destination resulted in booting to recovery only.

I have no idea how to proceed or what to do now. I attach the upgrade log (with escape sequences for colors and progress output,sorry for that).

Best regards,
Torsten

jetson-upgrade-5.0.2 (125.1 KB)

1 Like

Here are the logs from /opt/ota_package. Hope this helps!

xusb_only_payload.log (2.4 KB)
kernel.log (831 Bytes)
bl_only_payload.log (996 Bytes)

@herr.frei the debian packages based update we offer works out of the box for NVIDIA developer kits only. If you are using a partner product, then it wont work as it is.

Please raise a seperate forum issue and our forum team can help you.

Update: Containers for JetPack 5.0.2 is now available on NGC

Upon flashing my SD Card for my Jetson Xavier NX when I boot and do the initial configuration. I get a System program problem detected, and Ubuntu 20.04 has experienced an internal error.

Why is this happening, it doesn’t happen with the previous version.

You should probably start a new thread, mention this release, and if you are using a dev kit or something else. SD card models do have different requirements than eMMC models, as do different carrier boards. Combine this with a serial console boot log.

Update: Power Estimator for Jetson AGX Orin and Jetson Xavier NX are now live!

Hello…

I am trying to access the Jupyter on a remote machine in my lab - headless. It now needs token before you can change the password. The original nvidia password does not work. Attempting to persist a new password does not work because this is a docker container and is deleted in jupyter server when the container is removed. Is there a simple way to get the autogenerated token without doing a “server list” command and typing the token in on the remote machine? We do not want to run the graphics on the Xavier.

Thank you.

Hi @marvinbr, since Jupyter has changed the way it authenticates passwords/tokens, what I would recommend to persist a new password is after setting the new password, to save your changes to the container image with docker commit. Then afterwards, run your new container image instead.

You can get the tokens remotely by running jupyter server list from a terminal into your docker container, it doesn’t need to be done from the Jetson itself with a display attached.

2 Likes

Awesome …Thank you both. Both processes work. I will use the remote access version using SSH.

Why do we get this screen?


.

Will the new Jetpack 5.0.2 support UEFI Secure Boot? If yes for which Nvidia Jetson?

Thanks!
Max

@Max_Dichler securboot is supported till bootloader in this release for both Xavier and Orin (i.e, MB1, MB2 and until UEFI). In the next release we will support UEFI secureboot to sign componetns above UEFI like the kernel.

This release does not install for me on NVMe with the Jetson Xavier NX Developer Kit. Multiple attempts. It seemed to install successfully on uSD card, but my goal is to install to NVMe. I’m using latest SDK manager, JetPack 5.0.2 Rev 1. Was hopeful this would address the ridiculously bad installation problems of JetPack 5.x thus far. I am using manual install to SD and NVMe (the automatic install option never works at all).

Logs are attached. Everything I’ve tried with multiple, separate U20.04 host machines and multiple dev kits for NX and AGX have been enormous, time-wasting failures to install correctly.
SDKM_logs_JetPack_5.0.2_(rev.1)_Linux_for_Jetson_Xavier_NX_modules_2022-09-11_14-38-41.zip (428.4 KB)

It might also be helpful to know that no matter how I install it (NVMe/SSD) it never boots from NVME. It will never come up with NVMe mounted as the root filesystem. The NVMe device is recognized as nvme0n1 when the device is booted. It can be formatted and accessed normally by Linux on the device, but installation always fails to work properly.

Well it appears that it worked this last time because I removed the uSD card from the NX module. So perhaps this works now? Previously it would not let me flash NVMe first without flashing the image to the uSD card, but this last time it seems to have succeeded.

you are lucky! i have embed 16G eMC onboard. no chance to remove it. So I have to flash SD card.