JetPack 4.5 Production Release with L4T 32.5

We are pleased to announce JetPack 4.5, a production release supporting Jetson AGX Xavier series, Jetson Xavier NX, Jetson TX2 series, Jetson TX1, and Jetson Nano.

JetPack 4.5 includes VPI 1.0, Security features including enhanced secure boot and support for full disk encryption, enhanced bootloader functionality, and a new way of flashing Jetson devices using NFS.

We will be hosting a webinar on Feb 9th for an in-depth overview of JetPack 4.5 features where we will also demo select features and answer any questions you may have. Please register here.

Learn how to implement computer vision and image processing pipelines using VPI by registering to the webinar we will be hosting on Feb 11th

Highlights of JetPack 4.5 are:

  • First Production release of Vision Programming Interface (VPI).
  • Support for Docker 19.03.
  • Support for installing JetPack components on Linux host computer using Debian package management tool.
  • Secure boot enhanced to extend encryption support to kernel, kernel-dtb and initrd.
  • Disk encryption supported to protect data at rest.
  • New way of flashing eMMC, SDCard, USB or NVME connected to Jetson using Network File System.

Visit JetPack 4.5 and L4T 32.5 page for more details.

JetPack 4.5 components:

  • L4T R32.5
  • CUDA 10.2
  • cuDNN 8.0
  • TensorRT 7.1.3
  • VisionWorks 1.6
  • OpenCV 4.1.1
  • Vulkan 1.2
  • VPI 1.0 (First Production Release)
  • Nsight Systems 2020.4
  • Nsight Graphics 2020.5
  • Nsight Compute 2019.3

Install JetPack 4.5 using SDK Manager or upgrade via Debian package management tool (refer instructions from here)

Notes: (We will update this announcement accordingly when we take care of below notes)

is ubuntu 20.04 supported?

1 Like

Hi @Andrey1984, it is 18.04, however you could try this blog post to try to upgrade it to 20.04:

I haven’t tried this myself yet, so recommend backing up your work first.

Yes, this is the one that I was reffering to doing
sudo do-release-upgrade
on JP 4.4.1 OS.
it worked somehow to certain extent [ at least it boots/ operates somehow ] , also ROS2 foxy seems to build from apt package manager

anyone got easier step to follow this ? i follow the link but due to my knowledge i still confused

tensorflow seems missed?

ooking in indexes: https://pypi.org/simple, https://developer.download.nvidia.com/compute/redist/jp/v45
ERROR: Could not find a version that satisfies the requirement tensorflow
ERROR: No matching distribution found for tensorflow

reference steps: Installing TensorFlow For Jetson Platform :: NVIDIA Deep Learning Frameworks Documentation

tried flashing unit with

./flash.sh -N 192.168.x.x:/mnt/installation_nx_devkit/JetPack_4.5_Linux_JETSON_XAVIER_NX_DEVKIT/Linux_for_Tegra/rootfs jetson-xavier-nx-devkit eth0

after flashing oem-setup doesn’t complete. just gets hold after user creation menu
also, folks are asking how to get to U-boot dialog given NVME flashing has taken place
given there is no m.2 slot on host PC how should flash to nvme happen?
However, it seems direct nvme flashing for NX/ AGX is still not supported?

Hello , i have upgraded my Xavier AGX with a Kernel for some CSI-MIPI-Cameras i am using .

I don’t want to flash the board with fresh copy of jetpack 4.5 , how do i go about upgrading to Jetpack 4.5 , retaining my AGX Xavier Configuration .

1 Like

@dusty_nv it seems that it is possible to do a container with 20.04 from l4t-base

 docker run -it --rm --net=host --runtime nvidia  -e DISPLAY=$DISPLAY -v /tmp/.X11-unix/:/tmp/.X11-unix nvcr.io/nvidia/l4t-base:r32.4.4
apt install ubuntu-release-upgrader-core
do-release-upgrade
2 Likes

That looks promising - are you able to use CUDA/GPU from within the container after the upgrade?

Thanks - we are looking into why the jp/v45 wheels aren’t on the server yet, but for now you can still use jp/v44 on JetPack 4.5 still.

Hello, im currently on JP 4.4.1, how do i upgrade to JP 4.5?

Using the command… “sudo apt install nvidia-jetpack”, it said im already on newest version (4.4.1-b50).

Im using AGX Xavier.

@ArtofWar Can you check this post

Please change the second deb line to

deb https://repo.download.nvidia.com/jetson/t194 32.5 main

Thanks, i was running on Ubutu and it was having error connecting to server. Change back to unity and apt update works.

As per the doc OTA Updates the listed packages in the docs . Is there any way, i can choose not to update certain parts, like i do not want to update kernel-DTB’s , as i have already flashed my kernel with certain Nvidia Compatible hardware like MIPI-CSI Cameras and i do not want to go over the process of reflashing the kernel with Cmaera Drivers yet again !

Hello
I am trying to install Jetpack 4.5 cleanly to my Xavier AGX using SDKManager1.4 which was released newly.
SDKManager failed to install CUDA/CUDA-X AI and others after flashing jetson OS.

By checking Terminal log, i found out that apt-get update does not work.
error logs are below.
Any help will be appreciated…

ammr@xavier45:~$ sudo apt-get update
Get:1 file:/var/cuda-repo-10-2-local-10.2.89 InRelease
Ign:1 file:/var/cuda-repo-10-2-local-10.2.89 InRelease
Get:2 file:/var/cuda-repo-10-2-local-10.2.89 Release [574 B]
Get:2 file:/var/cuda-repo-10-2-local-10.2.89 Release [574 B]
Ign:3 https://repo.download.nvidia.com/jetson/common r32.5 InRelease
Ign:4 https://repo.download.nvidia.com/jetson/t194 r32.5 InRelease
Err:5 https://repo.download.nvidia.com/jetson/common r32.5 Release
Could not handshake: An unexpected TLS packet was received. [IP: 157.197.97.27 443]
Err:7 https://repo.download.nvidia.com/jetson/t194 r32.5 Release
Could not handshake: An unexpected TLS packet was received. [IP: 157.197.97.27 443]
Hit:8 http://ports.ubuntu.com/ubuntu-ports bionic InRelease
Get:9 http://ports.ubuntu.com/ubuntu-ports bionic-updates InRelease [88.7 kB]
Hit:10 http://ports.ubuntu.com/ubuntu-ports bionic-backports InRelease
Hit:11 http://ports.ubuntu.com/ubuntu-ports bionic-security InRelease
Get:12 http://ports.ubuntu.com/ubuntu-ports bionic-updates/main arm64 Packages [1,176 kB]
Get:13 http://ports.ubuntu.com/ubuntu-ports bionic-updates/universe arm64 Packages [1,496 kB]
Reading package lists… Done
E: The repository ‘https://repo.download.nvidia.com/jetson/common r32.5 Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository ‘https://repo.download.nvidia.com/jetson/t194 r32.5 Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I was able to boot into NFS by disabling oem-config

Flashing for NFS as root and Flashing from NFS features both requires booting into root file system hosted on NFS. Sometime due to the speed of network and the PC that NFS is hosted on, one might see that booting into NFS appears to get stuck for a long time while bringing up OEM-Config.

As a work around one can disable OEM-Config and create a default user which will make the boot to NFS file system by-pass the OEM-Config step.

One can follow the instructions at section Configuring NFS Root on Linux Host to configure the NFS server but add below step to disable OEM-Config after creating the root file system but before copying the root file system to NFS (refer to Setting Up the Root File System instruction on creating a root file system )

Step to disable OEM-Config and create a default username and password:

Step 1: Download and untar the attached file inside Linux_for_Tegra
l4t_create_default_user.tar.gz (2.5 KB)

Step 2: ./l4t_create_default_user.sh -u ubuntu -p ubuntu

After executing above steps, you can copy the root file system to your NFS.

If you are flashing form NFS, you can then follow the steps https://docs.nvidia.com/jetson/l4t/#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/flashing.html#wwpID0E0XG0HA

@Andrey1984 , please check this post regarding OEM setup during boot to NFS

1 Like

@dusty_nv
in certain cases using 20.04 In order to run cuda/gpu we need to [patch the gcc version], as otherwise there might be errors due to the gcc-9 (CUDA incompatible with my gcc version - Stack Overflow)

MAX_GCC_VERSION=8
sudo apt install gcc-$MAX_GCC_VERSION g++-$MAX_GCC_VERSION
sudo ln -s /usr/bin/gcc-$MAX_GCC_VERSION /usr/local/cuda/bin/gcc 
sudo ln -s /usr/bin/g++-$MAX_GCC_VERSION /usr/local/cuda/bin/g++

@suhash Thank you for sharing!
it works with the user creation script after copying the rootfs reated by sdkmanager atx86_64 host PC to jetson ssd over the network so that jetson boot will happen from other jetson. also it is handy as it also allows to chroot to the other jetson filesystem from local jetson

 # rsync -avzhprt  192.168.x.x:/path/rootfs_nx /path/

The original post states:

VPI 1.0 documentation will be available on Jan 22nd.

The official VPI docs are still on 0.4.4 as far as I can see: VPI - Vision Programming Interface: Main Page

I would like to check out the docs to see if it is worth upgrading, since I heavily rely on opencv types, and the new release is advertised to have better interop.

Is there an updated ETA? Right now I feel like a small child at christmas, checking every morning only to be disappointed :(