JetPack 4.4 - L4T R32.4.3 production release

We are pleased to announce the JetPack 4.4 production release supporting Jetson AGX Xavier series, Jetson Xavier NX, Jetson TX2 series, Jetson TX1, and Jetson Nano. (JetPack 4.4 replaces JetPack 4.3 as the latest production release.)

Please read an important NOTE at the end of this announcement

The JetPack 4.4 production release builds on top JetPack 4.4 Developer Preview, and includes production versions of TensorRT 7.1 and cuDNN 8.0.

Along with JetPack 4.4, we are introducing a web based Power Estimator tool to simplify creation of custom nvpmodel power profiles for Jetson.

Please refer to the JetPack Release Notes and L4T Release Notes for additional info.

JetPack 4.4 Highlights:

JetPack 4.4 components:

  • L4T R32.4.3
  • CUDA 10.2
  • cuDNN 8.0.0
  • TensorRT 7.1.3
  • VisionWorks 1.6
  • OpenCV 4.1
  • Vulkan 1.2
  • VPI 0.3 (Developer Preview)
  • Nsight Systems 2020.2
  • Nsight Graphics 2020.1
  • Nsight Compute 2019.3

Existing installations of JetPack 4.4 Developer Preview and JetPack 4.3 can be upgraded in-place to the JetPack 4.4 production release without re-flashing the device. For more information about upgrading JetPack via the Debian package management tool, please refer to the JetPack documentation here.

Download JetPack…https://developer.nvidia.com/embedded/jetpack

JetPack Release Notes…https://docs.nvidia.com/jetson/jetpack/release-notes/index.html

L4T Release Notes…https://developer.nvidia.com/embedded/secure/tools/files/jetpack-sdks/jetpack-4.4-ga/Jetson_Linux_Driver_Package_Release_Notes_R32.4.3_GA.pdf

Note: Jetpack/L4T upgrade using debian package management tool is now fixed and reenabled.

We had temporarily disabled the feature of upgrading JetPack or L4T using debian package management tool due to an issue we found in one of our debian packages causing the device to not boot properly. We have fixed this issue now and have reenabled this feature. We are sorry for the inconvenience caused.

3 Likes

Great! I’m really excited to test all the new updates!
Well, I have a Jetson Xavier NX Developer Kit and I’ve just flashed my 64GB MicroSD Card with the new JetPack 4.4 PR, but I’m having a problem with the fan. I was running jetson_clocks as usually, but this time the fan is not working.
Also I have run sudo service jetson_stats_boot status and it says in the logs: “sed: can’t read /usr/local/jetson_stats/fan_config: No such file or directory”.
Also, when I run jetson_clocks it doesn’t throw an error.
What could it be?
Greetings! And thanks for all the new updates!

Hello again. I’ve run sudo service jetson_stats_boot status on my Jetson Xavier AGX and it shows the same error, but the fans are working as usually, so maybe it has nothing to do with it.


As shown in the screenshot attached, the fans are working OK with the JetPack 4.4DP after running sudo jetson_clocks.
Fortunately, I had another MicroSD Card with that version of JetPack.
Now, I’m going to change again the MicroSD Card with the one that has JetPack 4.4PR and I’m posting an screenshot if it.

Hi Yelei,

We have made a change in jetson_clock to not forcefully set the fan speed to max but to control is based on the temperature. Hence you dont see the fan turn on with max speed with jetson_clocks. Hope it explains.

1 Like

Hi, @suhash ! Thanks for the quick response!
Actually I was writing about the other screenshot when suddenly the fan started working again but for around 30 seconds, and I didn’t know why, but what you said makes sense.
So this means that we won’t be able to set max speed anymore? And finally, at which CPU & GPU temperature the fan starts working?

Thanks for the warning about the bricking update. Unfortunately it came too late for me as I already had used the apt-get method of updating and was left with a non-working sdcard.

Baleno Etcher complains that the Image file is not flashable, both as a zip file and as an extracted file. It fails with the message:

Attention

Something went wrong. If it is a compressed image, please check that the archive is not corrupted.

alignment must be at most 4194304 bytes

No idea what is the issue here. Has anybody else been able to flash this image?

— edit —

I downloaded another copy of the image, but I got the same error. I am using a 64GB SDXC card, maybe that is the problem? Though I had not problems with the previous image file in that regard.

— edit 2 —
I’m going to switch back to the DP image (which was surprisingly difficult to find BTW) to see if that will flash, so I can continue work.

—edit 3—
The DP version gave me the same problem, so I had to conclude it was either the SDXC card (which worked with the original 4.4DP version without problems) or some issue with BalenaEtcher. I was using version 1.5.94 and checking their website I saw that they were now on version 1.5.100. Downloaded that and what do you know: the image for 4.4 Release is now writing to the SDXC card.

So if you run into this issue on Windows 10, upgrade to the latest version of BalenaEtcher!

Hello
The example application argus_camera now segfaults when calling “PROPAGATE_ERROR(m_deviceFocusPositionRange.set(iCameraProperties->getFocusPositionRange()));” which it did not on Jetpack 4.3 with tegra-l4t-r32.3.1

I am working on Jetson NANO devkit.

jetson_clocks still sets max clock rate for the given power mode as it used to. It’s just fan is no longer set to max speed by default. Fan on Jetson AGX Xavier will start to spin at 68C (first trip temperature: 50 C + 18C hysteresis). Complete thermal spec. can be found in power management document

If you prefer old behavior of jetson_clocks, please use --fan option which sets max fan speed:

jetson_clocks –fan

You can refer to power management document for details.

Too late about this warning for me, please update the thread with a path we can use to recover from the debian package upgrade. Currently I am looking a blank screen for the last 3 hours and my device is quite hot.

Hi,

If anyone get system stuck after running OTA update, please refer to this thread.

If we flash jetpack 4.4 on jetson nano then we have to install cuda 10.2 separately or not ?

Just a question regarding DLC because I am trying to update some custom installation scripts. Where can i find the contents of https://developer.nvidia.com/embedded/dlc/ for this release?

Jetpack 4.4 already includes cuda 10.2. So no cuda installation is required.

Jetson Download Center is here:

Is there any way to still do an OTA upgrade to r32.4.2? I am using an OEM carrier board in a sealed box and the only way I can currently upgrade to 4.4 preview is to start with their 4.3 image and upgrade to 4.4 preview.

But doing an OTA upgrade today updates to 4.4 production release. And this seems to imply that the production release of JetPack 4.4 is ONLY compatible with the production release of DeepStream 5.0

JetPack 4.4 supports the upcoming DeepStream 5.0 release

    • DeepStream 5.0 Developer Preview is only supported with JetPack 4.4 Developer Preview.

I upgraded a device today to 4.4 production and now our application which uses Deepstream 5.0 fails.

I tried setting /etc/apt/sources.list.d/nvidia-l4t-apt-source.list to 32.4.2 before doing the upgrade but it fails
Ign:16 https://repo.download.nvidia.com/jetson/common r32.4.2 InRelease
Ign:17 https://repo.download.nvidia.com/jetson/t210 r32.4.2 InRelease
Err:18 https://repo.download.nvidia.com/jetson/common r32.4.2 Release
404 Not Found [IP: 184.150.70.89 443]
Err:19 https://repo.download.nvidia.com/jetson/t210 r32.4.2 Release
404 Not Found [IP: 184.150.70.89 443]
Reading package lists…

Is there some way this can be fixed so we can still upgrade to r32.4.2 instead of r32.4.3

Thanks!

You can still install JetPack 4.4 Developer Preview using SDK Manager. Would that work for your case? APT upgrade to Developer Preview (32.4.2) is not possible anymore since we maintain debian packages per minor releases (32.x) and for 32.4, the debian packages in the server is upgraded to 32.4.3

The device is not an nVidia developer kit. It is a dev kit board on a custom carrier, i haven’t tried using the SDK Manager on this device. Can you just update the OS image without flashing everything via the SDK Manager?

Can I get the debian packages from somewhere else and install it manually?

I am extremely new to all of this.