Jetpack 5.1.3 Custom Board - Reset to recovery

We have a Jetson Xavier NX module. I’ve flashed the module with JP 5.1.3 and it boots successfully on the dev kit. However when we put it on our custom board, the module goes into “Rest to Recovery” mode.
It does complain about the CVM EEPROM… which I’m assuming is the module EEPROM

▒▒▒▒main enter
SPE VERSION #: R01.00.18 Created: Jan 29 2021 @ 14:18:27
HW Function test
Start Scheduler.
in late init
  [0000.917] I> Welcome to MB2(TBoot-BPMP) (version: default.t194-mobile-8e4b789e)
[0000.917] I> DMA Heap @ [0x526fa000 - 0x52ffa000]
[0000.918] I> Default Heap @ [0xd486400 - 0xd48a400]
[0000.919] E> DEVICE_PROD: Invalid value data = 70020000, size = 0.
[0000.924] W> device prod register failed
[0000.928] I> gpio framework initialized
[0000.932] I> tegrabl_gpio_driver_register: register 'nvidia,tegra194-gpio' driver
[0000.939] I> tegrabl_gpio_driver_register: register 'nvidia,tegra194-gpio-aon' driver
[0000.947] I> sdcard_params [0, 55, 0, 50] in mb1_bct
[0000.952] I> Boot_device: QSPI_FLASH instance: 0
[0000.956] I> qspi flash-0 params source = boot args
[0000.961] I> QSPI-0l initialized successfully
[0000.965] I> sdcard-0 params source = mb1 bct
[0000.969] I> Found sdcard
[0001.059] I> sdmmc SDR mode
[0001.080] I> Found 41 partitions in QSPI_FLASH (instance 0)
[0001.092] I> Found 22 partitions in SDCARD (instance 0)
[0001.093] I> Active Boot chain : 0
[0001.775] I> Relocating BR-BCT
[0001.776]  > DEVICE_PROD: device prod is not initialized.
[0001.778] E> I2C: Timeout while polling for transfer complete. Last value 0x00000002.
[0001.779] E> I2C: Could not write 0 bytes to slave: 0x00a0 with repeat start true.
[0001.780] E> I2C_DEV: Failed to send register address 0x00000000.
[0001.781] E> I2C_DEV: Could not read 256 registers of size 1 from slave 0xa0 at 0x00000000 via instance 0.
[0001.789] E> eeprom: Failed to read I2C slave device
[0001.793] I> Failed to read CVM eeprom data
[0001.797] E> Error getting EEPROM data!
[0001.801] E> cpubl: Parallel task execution failed
[0001.806] I> ▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒: execution failed
[0001.811] I> ▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒: execution failed
[0001.817] E> Top caller module: EEPROM, error module: I2C, reason: 0x06, aux_info: 0x05
[0001.825] I> Reset to recovery mode

Boot log attached
SOM_W3_boot_513.txt (11.6 KB)
Is the module EEPROM having an issue? The same module will boot ok on the dev kit.

However, I do have a bootlog from an earlier release of Jetpack, that seems to work on the custom board… which boots successfully
SOM_boot_success.txt (93.1 KB)

Then have you tried re-flashing this module while it’s put on your custom carrier board?
If it’s really about EEPROM on the module, then it should not make a difference what carrier board is used.

Thanks! It seems another chip on the I2C line was the issue. Works now.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.