Update JetPack5.1.2 problem

My machine was originally jetpack4.6 and now I am upgrading it to 5.1.2 and I am experiencing this problem

shell

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1
-c tools/kernel_flash/flash_l4t_external.xml
-p “-c bootloader/t186ref/cfg/flash_t234_qspi.xml --no-systemimg” --network usb0
jetson-xavier-nx-devkit-emmc external

problem

ASSERT [TerminalDxe] /out/nvidia/bootloader/uefi/Jetson_RELEASE/edk2/MdeModulePkg/Universal/Console/TerminalDxe/TerminalConIn.c(2078): ((BOOLEAN)(0==1))

Resetting the system in 5 seconds.
▒▒▒▒Shutdown state requested 1
Rebooting system …
▒▒
[0000.025] W> RATCHET: MB1 binary ratchet value 4 is larger than ratchet level 2 from HW fuses.
[0000.033] I> MB1 (prd-version: 2.6.0.0-t194-41334769-cab45716)
[0000.038] I> Boot-mode: Coldboot
[0000.041] I> Platform: Silicon
[0000.044] I> Chip revision : A02P
[0000.047] I> Bootrom patch version : 15 (correctly patched)
[0000.052] I> ATE fuse revision : 0x200
[0000.056] I> Ram repair fuse : 0x0
[0000.059] I> Ram Code : 0x1
[0000.061] I> rst_source: 0xb, rst_level: 0x1
[0000.066] I> Boot-device: QSPI (instance: 0)
[0000.070] I> Qspi flash params source = brbct
[0000.074] I> Qspi clock source : pllp
[0000.078] I> Qspi-0 initialized successfully
[0000.082] I> Boot chain mechanism: A/B
[0000.085] I> Current Boot-Chain Slot: 0
[0000.089] E> Error, current slot 0 fails: sr_bl: 0xd14ef1, sr_br: 0x0
[0000.095] I> Reset to recovery mode

My backboard is my own design, unofficial kit

log.txt (28.0 KB)

Hi,

You are not even using the right config for flashing…

Use flash_l4t_t194_qspi_p3668.xml instead of flash_t234_qspi.xml .

Hello,its failed

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 -c tools/kernel_flash/flash_l4t_external.xml -p “-c bootloader/t186ref/cfg/flash_l4t_t194_qspi_p3668.xml --no-systeming” --network usb0 jetson-xavier-nx-devkit-emmc external

Hi, I get stuck in uefi on my own backboard, and I have no problem using the suite with the same commands and environment.

Hi,

這個問題麻煩參考這一篇

原本那個人的問題是他會在開機時往UART送資料,但是這樣會讓UEFI錯亂
所以要在UEFI的device tree裡把UART關掉

這個麻煩找一塊DevKit驗證

我看不懂你這一句在說什麼

DevKit is ok!!!

DevKit is the same burning environment as my baseboard

Hello,thank you,its ok!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.