Jetpack update


I came across "The following packages have unmet dependencies:
framos-common-driver : PreDepends: nvidia-l4t-core (>= 32.7.1-0) but 32.5.2-20210709090126 is to be installed
Depends: nvidia-l4t-kernel (>= 4.9.253-tegra-32.7.1-0) but 4.9.201-tegra-32.5.2-20210709090126 is to be installed
E: Unable to correct problems, you have held broken packages.
when I tried to install a driver on Jetson Nano.
It seems the versions of the nvidia-l4t-core and the nvidia-l4t-kernel are too low to install the driver.

Any ideas how to fix this?

Hello zheng1,

I think your post is better placed in the Jetson Nano forums. I took the liberty of moving it there for you.


Thank you.

Are you using devkit or 3rd party carrier board?

I am using Nvidia devkit.

The same problem occurs again when I use the Nvidia Xavier NX development kit which has been flashed onto a Micro SD card by using the SDK manager.
It seems the version of the nvidia-l4t-core and nvidia-l4t-kernel are lower than expected.
How can I correct it?

Hi zheng1,

Could you help to try if the following command can fix the issue?

$ sudo apt-get -f upgrade

Have you tried to use SDK Manager to re-flash the board?
What’s the current Jetpack version in use?

Unfortunately, the command “$ sudo apt-get -f upgrade” doesn’t help.
The Jetpack version under SDK Manager folder (nvidia sdk) is JetPack_5.1.1_Linux_JETSON_XAVIER_NX_TARGETS

Is it possible that the driver needs an earlier version of Jetpack? If so, Is it possible to flash an earlier version OS by using a Micro SD image?

Solved by flashing an earlier version of Jetpack.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.