Jetson AGX Orin, Jetpack 5.1 and CUDA upgrade from 11.4 to 11.8 failed, need a bit of help

Dear Community,

I need to have onnxruntime-gpu working on my Jetson AGX Orin with Jetpack 5.1.
However, with jetpack 5.1 comes CUDA 11.4 and cuDNN 8.6.

The onnxruntime-gpu working with jetpack 5.1 only works with CUDA 11.8, so I tried to upgrade.
Following the instructions on the page, I made the error of selecting network deb type and ended up with CUDA 12.2 installed instead.

Now I tried to redo it with local installer type, but the package manager keeps telling me that the latest version of CUDA (12.2) is already installed. I tried removing the keyring with sudo apt-key del 7fa2af80 and ran sudo apt-get update but although I copied the cuda-tegra-repo-ubuntu2004-11-8-local/cuda-*-keyring.gpg key in the keyring, following the local installer instructions, apt-get still tries to install the CUDA 12.2 version.

I guess I’m not too far from the truth, but I need help to move on here.
I currently have the CUDA 11.4 and 12.2 versions installed and my goal is to end up with only the 11.4 and the 11.8 versions.

Could anyone help me with this please?

Thank you very much in advance for your esteemed help


When using a package manager method to install a CUDA version that is older than the most recent one available, you must call that out specifically e.g. apt-get install cuda-11-8. Based on where you are now, it may be sufficient to do apt-get install cuda-toolkit-11-8

More instructions are available in the CUDA linux install guide (linked from the download page)

However there are nuances to Jetson setup. For that reason, you may get better help by asking on the Jetson AGX Orin forum.

Hello Robert_Crovella,

Thank you very much for your help, it was indeed all that was needed :-)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.