Jetson AGX Orin shows Test key warning when booting


I was trying to upgrade Jetpack to 5.02 on AGX Orin refering to this announce(Jetpack 5.0.2 with Jetson Linux 35.1 is now live!).
The following is What I did

To upgrade from JetPack 5.0/5.0.1 Developer Preview:

First edit etc/apt/sources.list.d/nvidia-l4t-apt-source.list to first point to 35.1 repo (just change the version to r35.1 in both lines) and then use the following commands, then physcially reboot the system:

sudo apt update

sudo apt dist-upgrade

sudo apt install --fix-broken -o Dpkg::Options::=“–force-overwrite”

The last line is required because in JetPack 5.0.2 release cuda-nvprof-11-4 package was renamed.

Then I executed “reboot” command on the terminal to reboot the device.
However when the device is booting, the display showed the warning below and after only 2 or 3 seconds, the display turned black and the fun stopped although the power button was still on.
The fun started to work after a while but display still doesn’t work.

Jetson UEFI firmware (version r34.1-975eef6 built on 2022-05-16T20:58:45-07:00)

** WARNING: Test Key is used. **
L4T boot options
0: primary kernel
1: Custom Header Config: <HDR40 User Custom [2022-06-24-193156]>
Press 0-1 to boot selection eithin 3.0 seconds.
Press any other key to boot default(Option: 1)
EFI stub: booting Linux Kernel…
EFI stub: Using DTB from configuration table
EFI stub: Loaded initrd from LINUX_EFI_INITRD_MEDIA_GUID device path
EFI stub: Exiting boot services and installing virtual address map…

(The last 4 lines appeared in a moment, then the desplay goes black.)

I tried to type any key but it didn’t work.
Could you tell me how to turn it on?

Thenk you.

hello taitai,

please setup serial console, is there any addition logs for reference?

Hi taitai,

Thanks for bringing it up.
I also have the same issue. Could you find a solution for this?


Hello, baha2r

I’m sorry I’m afraid I haven’t found any solution yet.
I’m working on it now.

Thank you for your kind reply.
And I’m sorry for latte reply.

I’m trying to set up the serial console but the host PC(ubuntu18.04.6) doesn’t recognize jetson.
Maybe I can’t use serial console with ubuntu18.04.6?
Or can I get some documents to refer?

Thank you.

hello taitai,

please see-also Jetson AGX Orin Developer Kit User Guide - How-to | NVIDIA Developer,
you may use micro-B to gather debug uart logs.

Thank you.

I tried to confirm the serial device by writing ls -al /dev/ttyACM* on command prompt but I found no file although the host PC was connected to jetson thurough micro B you refered.

How can I make the host PC detect the device?

And after the host PC detect jetson ,can I get the logs by refering to Setting up Minicom Client - Ubuntu - RidgeRun Developer Connection and NVIDIA Jetson Orin - Serial Console (

Thank you.

FYI, if you run “dmesg --follow” on the host PC, and then plug in the fully running Jetson (or plug in and then power up), you should see some new log lines associated with the device. This can tell you what device is detected.

hello taitai,

yes, you can use the serial port utility to gather logs. you may setup the connection before Orin power-on.

Thank you for your advice.

I tried what you taught me but it didn’t work for me.
I uploaded the video in which I followed your advice.
So, could you tell me whether the procedure is right or wrong and what to change.

Thank you for your time.

Thank you for your reply.

And I’m sorry for asking you many times.
Is there any way to confirm if the host PC detect the serial port device and which number I should type at the * of “minicom -D /dev/ttyACM* -8 -b 115200”?

Thank you

When you connect the cable to your host PC, check the dmesg on your host PC…

Dmesg will tell you the kernel log and if the node is really generated, it will show /dev/ttACM0 got generated. Otherwise, either error comes out or even nothing got printed in dmesg.

If nothing got printed, please make sure your micro usb cable really has data line but not only power line.

Thank you for your advice.

I foound that my cable was broken.
Now I’m using another cable and that works well.
Thank you.

Hello JerryChang

Thanks for your all advice, I was able to get the boot log(I uploaded below)
Could you tell me what I shoud do next?

Thank you for your time.

log (125.9 KB)

hello taitai,

that’s booting up process for checking keys, that’s 256-bit key to sign/encrypt UEFI.
if you’ve not assign keys, it’ll use test key and pop-up this warning messages. you may ignore this for your development process.

hello JerryChang

I can boot up and login jetson through minicom but as I mentioned in Jetson AGX Orin shows Test key warning when booting, the display blacks out after the booting process.

How can I solve the issue?

Thank you.


Every line in your log is truncated… please dump the log again and read the log before you shared it out…

For example, the line here is not full one… there are still information after “2”…

[ 0.000000] Linux version 5.10.104-tegra (buildbrain@mobile-u64-5273-d7000) 2

Hello, Wayne

I’m sorry for sending lack log.
I upload the full log bellow.
I think that it is a full file but because of my poor knowledge, I can’t confirm it by myself.
So, I’m sorry maybe I sended lack log again.

log (87.7 KB)

And I tried “sudo apt update” , “sudo apt dist-upgrade” and " sudo apt install --fix-broken -o Dpkg::Options::=“–force-overwrite” "again.

And I found that some error happend on “sudo apt dist-upgrade” and " sudo apt install --fix-broken -o Dpkg::Options::=“–force-overwrite” "
I upload the messages that was shown on host PC through the minicom.

–fix-broken (8.3 KB)
dist-upgrade (8.8 KB)

Thank you for your time.

Hi @taitai

  1. Sorry that the log is still truncated… but it is okay. Does not matter now.

  2. So currently, you didn’t upgrade your system successfully at all?

My personal suggestion is, if you are not dedicated to study those bootloader update procedure, how about you just directly reflash your board with sdkmanager?