Jetson AGX Xavier Industrial Booting issue intermittently all of a sudden


My Jetson hardware was working fine for 2 weeks, but all of a sudden it is having booting issue, even though the flashing is successful from the host PC.
Please find the image for more details:

Please let me know , what could be the root cause all of a sudden,

Note: I am following the same kernel build and flashing process.
I am updating some dtsi files for configuring my CANs , GPIOS and I2S audio related interfaces. Is there any chance this is causing any problem?

I tried loading my old working image file/dtb files/ cfg file, but still the boot issue pertains. But if we replace this SOM module and put another SOM module on the same customized carrier board, it boots fine. so we are clear that the issue is with the SOM module.

We don’t use a unclear photo of your monitor to debug issue.

Please dump the boot up serial console from another host.

sorry I am not in a position to get the boot log now urgently, will try to provide later.

but need to fix this boot issue as soon as possible. Kindly request you to let me know if you have any vague idea why booting is stopping in the middle. Thanks.

If you cannot dump log and want to get things fixed, my suggestion is put this SOM to NV devkit and flash with pure sdkmanager image.

That is the only thing I can guarantee working.

1 Like

That sounds very good idea. Will try this out. Thanks.

Pls find the zoomed up pic, with clear booting log msgs as shown below:

You don’t get the point. My point is these words do not matter. No matter how much zoom in you try, it does not help.

1 Like

oh ok.

Shall I download ubuntu alone or docker image download is required

ubuntu one.

1 Like

FYI, the image shows normal boot up to that point. The failure is something after that image was taken.

1 Like

Thanks for the info.
I assume this problem started appearing after:

  1. I executed flash command to flash only my. DTB file passing it as parameter like as shown below:
    $ sudo ./ -d ./kernel/dtb/tegra194-p2888-0008-p2822-0000.dtb jetson-agx-xavier-industrial mmcblk0p1


I executed flash prerequisites .sh script ( for the first time before flashing, Earlier I was directly executing Flash command ) as shown below:

$sudo tools/

Any idea about this. Please let me know. If either of these are causing any problems after booting and once it enters the kernel.

To fix my booting issue , was trying to load the kernel image file alone separately but getting this failed flashing error.
using the below command:
sudo ./ -K /home/trident/Downloads/r35_4_1/Jetson_Linux_R35.4.1_aarch64/Linux_for_Tegra/kernel/Image.gz jetson-agx-xavier-industrial mmcblk0p1

Any idea why this error is occuring?

A better way is just use full flash to avoid anything wrong. I actually don’t know what are you doing with that -K image.gz.

As the website documentation was trying to load only kernel image file with parameter -K and actual image path being passed, to see if it Boots fine.

Honestly, you are just wasting time here if you cannot provide logs.

Also, if you change some variables and lead to board cannot boot, change your variables back to original.

I think the commands you are using are incorrect and probably have flashed more than you think. I don’t know enough about the options such as “-d”, but that command very likely flashes more than the DTB, and uses a specific DTB you named while adding more than the DTB.

Luckily it worked when I did full flash with the old backed up DTB files and Image file.

Later I took old code and did fresh kernel build and it started flashing and booting fine.

Luckily it worked when I did full flash with the old backed up DTB files and Image file.

Later I took old code and did fresh kernel build and it started flashing and booting fine.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.