Brand new Jetson AGX Xavier doesn't boot

I got a brand new Jetson AGX Xavier and it doesn’t boot at all. The very first time, I got the same error as posted on this forum entry screenshot:

The message says “a start job is running for End-User configuration after initial OEM installation”. The message also clearly says that it’s going to be stuck forever.

I tried Ctrl-Atl-Del several time. OFF and back ON cycles. It’s still stuck (although the messages have changed). I also get an error saying that a USB Flash port could not be properly setup. The USB port works since I could use the keyboard.

“Failed to start Configure USB flashing port for device mode.”
“See ‘systemctl status nv-j4T-USB-device-mode.service’ for details.”

The last message after the additional reboots are about UTMP

“Started update UTMP about system Runlevel changes.”

Finally, the screen flashes. It shows the boot info and then flashes to black, shows the text, flashes to black, etc. I tried with two completely different monitors, sure enough it did the same thing so it’s not the monitor that’s the culprit.

What do I have to do to use my brand new Xavier board?!

I faced your issue when flash JP4.3 and JP4.4 DP at my dev kit.
But I succeed after I reboot(use reset key) the devkit. After I reboot, I can enter user name and password.
But you mentioned you have always faced this issue even OFF and ON, which I didn’t face.

I think maybe you can try reset when the issue happens.
If the problem is still there, you should contact your reseller to help(after sale service is also very important.).

1 Like

So you flashed newer versions and ran in the problem but you did not have to flash an older version, it just finally booted with the newer one?

Exactly.
After reset, I can enter username and password in the initialize UI. Then I enter IP address in sdkmanager to install the other deb like cuda.

1 Like

Hi,

User needs to create user account and password in their first boot up and it can be done through either of below methods

method 1. User the monitor and it will show the UI prompt for you to enter the account and password
method 2. Use the oem-config through micro usb cable. In this method, you need to install console tools like minicom and picocom on your host. Connect the micro usb cable between the tegra and your host. Then, use minicom to open /dev/ttyACM0. It shall show the configuration prompt on your host side.

If you get stuck on (1), then maybe you could try method 2.

WayneWWW,

What are you talking about?

Shouldn’t the Jetson AGX Xavier just boot right up to a lightdm prompt?

Why are we talking about a Tegra?

What is that nonsense about using minicom? I never had to do that with my Jetson TX2. Is that to change the boot configuration? Why do I have to do that on a brand new board I booted for the first time?

You’re just not making any sense. Sorry.

Hi,

I would say maybe you could also flash your tx2 with rel-32 and see what is going on.
What I was telling is added after rel-32. You will see TX2 ask you to configure user account on monitor too.
I know you didn’t need to do such configuration in rel-28 period.
Unfortunately this is not decided by me. If you don’t want to try the method, then I cannot help.

Hi,
Please check


https://leginfo.legislature.ca.gov/faces/billTextClient.xhtml?bill_id=201720180SB327

Due to the law, users have to create username/password in the first bootup. Please connect to a monitor and see if you can boot to the stage of requesting for username/password registration.

1 Like

You might also check out the script “l4t_create_default_user.sh”. This adds the content to the “rootfs/” prior to generating an image (and it is still the end user doing this if you are flashing it for yourself, and only needs to be run once).

Hi DaneLLL,

Now that makes a lot more sense. The screen flashes to black and it’s still in the boot process, so nothing is asking me for a password.

Could having the board connected via network be an issue? Should I start these devices without an Internet connection the first time to have a chance to reach such a place as a prompt for a name/password? Or does it only work through the minicom?

Hi,
The latest production release is Jetpack4.3. Please do clean re-flash through SDKManager and check if the issue is still there. If you don’t boot to the Ubuntu desktop that requests for setting username/password, please attached the uart log for reference.

For fetching uart log, please check:
https://elinux.org/Jetson/General_debug

Hi,

Below is the solution if your monitor keeps blanking and no response.

If you are using xavier devkit, please connect the type c cable to the port you used to flash the device. Your host shall have a device node generated as /dev/ttyACM0. Please use minicom or picocom to open this node and the oem-config tool will show up on your host screen to ask you to configure the account. Then, you don’t need to configure it through the monitor on Xavier anymore.

Hi,

We did encounter the configuration issue sometime after device flashed.

Sometimes, this issue could be solved by connecting to another HDMI monitor.

After agx xavier boot to the Ubuntu desktop, the agx could be connected to original monitor to use.

By the way, I do think oem-config tool which WayneWWW provided might be a good way to do. I will try it. It’s good for using as no extra HDMI to connect.

Thanks,

Hi,
I just got a brand new Nvidia Jetson AGX Xavier; I created the image and successfully created a user after booting up. After that sequence, the screen is always black. I installed minicom on my mac and connected the cable to my Nfidia AGX, but do not see a device /dev/ttyACM0 on my mac. Any suggestions?

Thanks,
Alistair

I created the image and successfully created a user after booting up.

If you already created a user account over the monitor and it got blanked after this, then this is different issue.
Please try to use serial console to dump the boot up log with us.

https://elinux.org/Jetson/General_debug

I think I saw in the past where people with a Mac may have had some compatibility issue. Unfortunately, I do not have a Mac. I am curious if anyone here can remember serial port issues which needed to be adjusted for on a Mac before the ttyACM would work?

Okay, I got things to work by flashing the latest version and looking at the screen. This time it had rebooted and offered me to accept the license and setup my account.

The minicom connection did not work until later. Maybe the computer was still booting when I tried. That is, I can see the login prompt now, but I’m done setting up the device so it actually boots.

For minicom, note that you need to use it properly (correct speed, bit parity…) I found this page about it: https://developer.ridgerun.com/wiki/index.php?title=Xavier/In_Board/Getting_in_Board/Serial_Console

minicom -D /dev/ttyUSB3 -8 -b 115200

Part of the Flashing process the device gets rebooted automatically. When I looked at the screen (because minicom didn’t work) it had booted and was showing a window in what looked like X-Windows.

So now I’m on track to getting my device to work. Thank you.

I’d like to further mention that with the other two devices I have, the problem did not occur. However, I did NOT connect the devices to the Ethernet before turning them on.
What I would suggest is for NVidia to include a note in there that you have to boot once without any network connection, WRITTEN IN BIG ON THE DEVICE, so that way idiots like me can do it right first time. :-)

What I would suggest is for NVidia to include a note in there that you have to boot once without any network connection, WRITTEN IN BIG ON THE DEVICE

Actually, there is no such rule that you cannot connect ethernet cable in first boot. Such error somehow happens to some users. Also, we don’t see any connection here between this issue and the network connection.

Maybe not, but some other people have reported that too. If they connect the Ethernet cable it won’t boot correctly. So I would imagine that the rule may not be written or known, but maybe it’s still a requirement.

Have you tried to start one of these out of factory with a connection to the Internet before you power the system?