Jetson nano about PCIe switch

We connect a PCI switch through the two line PCI bus of Jetson nano. I can see the identified bus under lspci, but the bus can not be used. When I check the log, I will make the following error


pci-log.log (76.5 KB)

Now we can recognize a upd720202 device but it can’t work. The LED on the hardware indicates that the device has been disconnected

this is my device tree setting, ”nvidia,disable-clock-request“ its my add

Can you please attach ‘sudo lspci -vv’ output? I’m wondering if ASPM states are enabled for the link.

this is lspci msg lspci.log (41.5 KB)

I see that PCIe ASPM states are enabled.
Could you please add ‘pcie_aspm=off’ to the kernel command line?
Alternatively, you can set CONFIG_PCIEASPM_PERFORMANCE=y (instead of CONFIG_PCIEASPM_POWERSAVE=y) in the kernel configs. I hope this would solve all the issues.

ok thanks !im try

thanks ,im try comfig CONFIG_PCIEASPM_PERFORMANCE=y ,now it can be work

1 Like