How to disable PCIe ASPM permanently

Hi
The Jetson nano image has an issue on my Intel WIFI adapter as below:

[  741.263416] pcieport 0000:00:01.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=0008(Receiver ID)
[  741.274752] pcieport 0000:00:01.0:   device [10de:0fae] error status/mask=00000001/00002000
[  741.283347] pcieport 0000:00:01.0:    [ 0] Receiver Error         (First)

Based on the info in this forums, it may be the PCIe ASPM in power save mode. I tried in command. It looks like work. Would you please let me know to disable PCIe ASPM permanently step by step.
Thanks

CX

Hi,

The method to permanently to disable ASPM are two opitions

  • Disabling from the beginning
    • Appending ‘pcie_aspm=off’ to the kernel command line (boot/extlinux/extlinux.conf)
    • Removing “CONFIG_PCIEASPM_POWERSAVE=y” and setting “CONFIG_PCIEASPM_PERFORMANCE=y” in the kernel configuration

where is the kernel configuration file?
Thanks

tegra_defconfig in the kernel source.

This step requires you to download source code and rebuild the linux kernel.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.