Wi-Fi disconnection in Jetson Nano with Intel AC-8265 Wi-Fi module

We have interfaced Jetson Nano Production Module (4 GB) with the Intel AC-8265 Wi-Fi module.

In our application, we are generating Access Point in Jetson Nano and an android device is connected to that Access Point
We are facing an issue with Wi-Fi disconnection in the Android device i.e. the Android device is disconnected from the Access Point automatically, but at the same time, other devices are connected with that Access Point.

We are looking for a solution to this issue.

The specifications of our system are listed below
Jetson Nano Production Module (4 GB)
OS: Ubuntu 18.04
L4T (Linux for Tegra) version: 32.5.1
Jetpack version: 4.5
Kernel version: 4.9
Wifi Chip: Intel AC-8265

Could you clarify more about the issue here? not quite understand.

Hello @alanz ,

In our product we need to connect Android Tablet to Jetson Nano Board. And they both should be in continuous communication over Wi-Fi.
Fyi, Jetson Nano is only able to create hotspot (AP) at 802.11n -20MHz mode.

Now as mentioned by @vivek_rawal, sometimes Tablet drops the Wi-Fi with Jetson Nano. Hence, communication breaks which results into stop functioning of the product.

Moreover, we were checking and found that Jetson TX2 has power saving mode, when it is connected to router.
We tried to turn off Power saving mode in from Jetson Nano (it works when jetson is not configured as AP) but, the method does not work when Jetson Nano is working as AP.

below is the link we followed:

Is there any other way to turn off Power saving mode to jetson Nano while it acts as AP?

Kindly understand the issue and guide us how we can solve this.

Actually the title should be for this topic,
[Wi-Fi disconnection with target devices when Jetson Nano hosting hotspot (Intel AC-8265 Wi-Fi module)]

@MilanP , has briefed you about the issue
do let us know if any more info needed.

Let’s have a quick try with systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target .

Pls let me know if there is still the disconnection, if yes, pls share the log here.

yes, we tried out with above mask.
The result is same. We had the disconnection problem after few hours.

kernlog.txt (1.1 MB)
syslog.txt (13.1 MB)
dmesglog.txt (91.2 KB)

Pls try to disable the ASPM state and test again.

"echo "performance" > /sys/modules/pcie_aspm/parameters/policy"

Thanks for help
We have implemented this, we will continue to test with this next 2-3 days,

@alanz After disable of ASPM state by “echo “performance” > /sys/modules/pcie_aspm/parameters/policy”, disconnection issue is decrease, but it is still getting disconnected from android device.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.