Jetson nano can't shutdown

I just met a strange thing that I can’t shutdown Jetson nano by any of the following method:

  1. from top right corner of the window, select power and shutdown and then click on shutdown button. This resulted a Ubuntu login window. After typed the log in password, a Nvidia log displayed for a while and back to the normal windows after boots up.
  2. from the terminal type the command “sudo shutdown -P now”. Nothing happened.
  3. type “shutdown” in terminal. It display “shutdown scheduled for …, use ‘shutdown -c’ to cancel.”, but it never shutdown.
    The only way to shutdown is switch off the power to Jetson nano.
    I will switch off the power now and see what is going on…

After switch off the power and power on reboot successfully.
Why can’t shutdown?
How can I fix it?


hello changwen.xie,

may I know your software and hardware environment setups.
for example, which JetPack release you’re using. $ /etc/nv_tegra_release; what’s the power-supply you’re using, did you enable auto power-on?
besides, please also setup the serial console to gather the complete logs for reference,

The hardware is jetson nano developer kit. The carry board is type B (2 mipi camera ports). Hardware connected to the developer kit are:

  1. USB 3.0 camera.
  2. Intel WIFI adaptor configured as an access point
  3. HDMI output to a monitor.
  4. USB keyboard and USB mouse
  5. GPIO (40 pins): I2C port connected to I2C component. UART-2 connected to another micro-controller.

The message in /etc/nv_tegra_release is as below:

# R32 (release), REVISION: 6.1, GCID: 27863751, BOARD: t210ref, EABI: aarch64, DATE: Mon Jul 26 19:20:30 UTC 2021

Power supply (STONTRONICS, MModel: SAW36-050-4000B, input: 100~240V, 1.3A. Output: 5V, 4000 mA) connected to power jack J25.

The connection J50 as below:
Pin 5 and 6 connected: disable auto power-on
Pin 11 and 12 connected to a power switch.

The strange case was only happened once yesterday. I will keep my eye on it and log the message from console if happened again

hello changwen.xie,

did you mean you’re able to issue software commands to shutdown the system now?

Yes. After power cycle (unplug and plug the power supply to the carry board), I can shutdown the system now.
But I do need to find out the root cause and sort it out as our product application program based on different case to control Jetson nano enter sleep mode or shutdown. Otherwise, it will affect our product on market.

hello changwen.xie,

please setup serial console to gather the logs,
for further debug, you should also rule out the reproduce steps to recreate the issue locally.

I have setup the serial console to log the info already. But I don’t know the reproduce step yet as it happened only once.

Based on my memory what I have done yesterday, I have reproduced the case in following steps:

  1. Run video streaming using gstreamer.
  2. Run other application program and web browser to make the Swap memory used more than 15 (this is the number on yesterday). Today tried it at 24.
  3. Close all the application program.
  4. check the memory used by free -m. The used swap is 24.
  5. Click suspend from top right corner to suspend Jetson nano.
  6. waiting 5 seconds and then press space key on keyboard to wake up.
  7. Click shutdown and select restart. At some point, it asks the login password and then display Nvidia logo. waiting about number of minutes, the normal windows appears after boots up successfully.
  8. from terminal, type sudo shutdown -P now, nothing happened. See screen captured below

This is the serial console log file for you to investigate:
teraterm.log (43.4 KB)

Would you please let me know are there log files from Jetson nano to be uploaded to you or any other test needs me to carry out at the time Jetson nano can’t shutdown?

I tried shutdown by selecting shutdown from top right corner icon. It appears as the restart process. i.e. At some point, it asks the login password and then display Nvidia logo. waiting about number of minutes, the normal windows appears after boots up successfully.
I monitored the serial console, it has not any message output to the console.
The Jetson nano is working: video stream, WIFI connection, Web browser, Qt creator, but can’t shutdown

hello changwen.xie,

may I also know which Nano platform it is. for example, Nano 2GB?

the error log, ERROR: BPMP not powered on, it could be ignored. since there’s no bpmp on Nano series.
for example,

[ 5723.771049] IRQ12 no longer affine to CPU3
[ 5723.775611] CPU3: shutdown
ERROR:   BPMP not powered on

hello changwen.xie,

I saw some failures report by peripheral devices, for example, pcie, wifi, could you please removing them individually to narrow down the issue,

It is 4GB Jetson nano

I only plugged into a Intel WIFI module. I don’t know which hardware component is using PCIe.


If you are using the m.2 key E on jetson nano devkit for your WIFI, then it is using PCIe.

This is the WIFI module I am using:

If you think the issue may be from this module, I may take it out and try again. Is there any other WIFI module best compatible with Jetson nano for recommendation?

What we are doing now is just debug. We don’t know if this is caused by wifi. Just try to remove all of these and see if issue is still.

I have tested with and without Intel WIFI module. I am sure, the issue is NOT the wifi module.
Further test in progress