Jetson Nano not rebooting


Last night I set up my Jetson nano using a 16GB microSD card, powering from a 5V / 4A power supply (J48 is jumpered).

It went through the setup and configuration process fine, I was able to play around with ubuntu and all. I then had to leave so I closed all applications and left the computer running as-is.

Latter that night I accidentally pulled the plug on the power.

Now this morning I plug the power back in, the device powers up and I see the initial nvidia splash screen, but then nothing happens.

I haven’t tried re-flashing the microSD card yet, I’m going to do that next, but is there anything else I should try or trouble shoot?

I know the device is powering usb, the red light under the mouse is on and if I hit caps lock or num lock keys, the lights light up.

Also, I’m trying to look for literature on how to properly power down the device. I know it sounds like a silly question, but can someone please point to where I can find how to properly power down the nano?

Many Thanks!

Hi icornejo.a,

If you want to power down the nano device, you can remove power supply (power adapter or usb cable) or you can press shutdown button from Desktop menu.
You can check more detail from user guide:


Any update here?

Hi guys;

Thankfully I got the Jetson Nano working again.

The solution, for whatever reason, was using a different SD card.

I tried re-flashing the SD card to see if that got the nano working, no go.
The card was recognised by Etcher, and it re-flashed and passed all validation test but no go. Same result as above.

I just bought a 64GB card, flashed it and put it in the nano. Everything is working fine.

I’m going to close-off this thread, but I will follow up when I try the original 16GB SD card to see if it woks or not.