Jetson Nano 4GB not powering on

Hi everyone,

I recently purchased a Jetson Nano 4GB board, but I’m facing an issue where the board is not powering on (First time). I have tried multiple power supplies, but the board does not show any signs of life, and the power LED does not light up. I have also checked the microSD card and ensured it is properly inserted. However, I’m still unable to get the board to power on.
I have already attempted the following steps:

  • Tried multiple power supplies.
  • Checked the microSD card. Any help or guidance would be greatly appreciated. Thank you in advance!

Hi, what’s the power of the power supply you are using?
If you want to power your board up with the DC jack, then the power supply has to be at least 5V/4A.
For Micro USB, it has to be 5V/2.5A.

If it’s still the case, consider sending it for RMA.

Hello @DaveYYY , I found the problem. The Jumper was not fixed in the right place

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.