Jetson Nano 4GB Getting Started (Powered with Barrel connector )

Hi all,I am very new to Jetson.I was trying to set up my new Jetson Nano folowwing the getting started instruction .
I have set up J48 Jumper ,Connected SD card in the slot and connected

  1. HDMI to my monitor
  2. USB Logitech Camera
    3.USB Keyboard and Mouse
    I am using waveshare 5V -4Amp power supply with 2.1 mm jack.
    When I connected the power supply after the setup as per the documentation ,I was supposed to see led near micro usb being lit and I was hoping to see display in monitor.But I cant see any response from the system. I have checked the Power Jack if it was getting 5V and it was getting 5V.
    Please help me find the issue with the board .

Thank you in advance

Does the LED on board light up when you power on it?

No .The LED not lit.

Power Supply details

Waveshare Power Supply Applicable for Jetson Nano 5V/4A OD 5.5mm ID 2.1mm (US Adapter only)

Is micro usb able to power on your board?

I havent tried with Micro USb power supply.I only have wave share power supply with me.

Hi I tried qith micro uSB charger (used for cell phones charging) .The led still doesn’t light up

Hi, did you download the image and write it to the microSD card? If you have totally followed the Jetson_Nano_Developer_Kit_User_Guide to set up, then it looks like a hardware issue which might need RMA.

I had written image to microSD .There are multiple partitions like around12.(which i saw from the forum that is normal).By the way I am using windows 10.
What is RMA?

Here are the RMA steps: Jetson FAQ | NVIDIA Developer

Thank you everyone for the help.I haev sent the Boards as RMA

I got my new device after RMA.

  1. I was able to set up the new device with power through USB micro connector .I had an error message on ubuntu desktop “system throttled due to over current”.(power out DC 5V,700mA)

2.When I connect my Power supply (5V,4.0 A) its not booting.I am not able to see any LEDS light up.I have measured the power supply and i can measure 5v at the DC barrel output.
Kindly advice


I have measured under the barrel connector(leads) with power supply on and its giving 5V out put

Issue resolved with proper jumper setting.