Jetson Nano doesn't turn on

So I just got my Jetson Nano today. I prepped the Micro-SD card, put it in and connected a Raspberry Pi 2.5A adapter to it. Nothing happened. The LED doesn’t turn on at all. No HDMI output. Absolutely no sign of life. I’ve tried a few other power supplies (though admittedly none of them is as reliable as the Raspberry Pi one). None of them did anything.

So do you think there is anything I might have missed? Any suggestions as to how to diagnose the issue?

It seems common that some supplies don’t work (Jetsons are somewhat picky about getting correct power delivery during the initial “on” spike which is too short to see). If you have another adapter (preferably higher rated), then perhaps that will work. If someone else has the RPi 2.5A adapter, then maybe they can jump in and say if it works for them.

In my testing you really need a 5v, 4a barrel jack adaptor to power it. I have a lot of adaptors around that works with even very picky Pis and none of them would power the nano enough to survive any stress testing. It did power up, but it wasn’t stable. Also, if pin j48 is jumped, micro-usb power is disabled (you will need to do this if you use the barrel jack). That could be it, but my kit came with no jumper.

God only knows that I’ve seen my fair share of power issues with Jetsons (TX2’s) at work, but don’t you guys think that even with a sub-par power supply there should be a flicker of light in the LED or something?

Also, no, J48 isn’t jumped so there’s that. I’ve already ordered a barrel jack. I’ll get it in a couple of days, but still I’m worried the board or the module might be broken.

Maybe tomorrow I’ll try a power supply a friend of mine has had success with (another Raspberry Pi power supply).

So I tried a barrel jack power supply and that didn’t work either. All of these power supplies work fine with my friend’s board, so I’m assuming either the carrier board or the module is broken somehow.

I’m guessing you did jumper J48, but it is worth mentioning to check.

If you were able to test against another board, then it sounds you’re correct and you should RMA it.

It wasn’t jumped for testing Micro-USB power supply, and it was for barrel jack, so yes, I did pay attention to that.

I’ve emailed Seeed Studio. We’ll see what happens. It was just a bummer. I was hoping for a weekend project.

J48 made barrel jack work for me. It’s kinda awful they couldn’t be bothered to ship it with jumpers considering the page I bought from (new-egg) recommended the adafruit barrel jack to ship with it.

Hi i have power problem wiht my jetson nano. It worked fine during a week with 5v/4a power supply and j48
Today after reboot pwr led do not trun on. I test board with multimiter and there are 3.5v on it. But led do not turn on. And i can’t connect to board by UART. What was happend with my jetson?