Jetson Nano never works and never lights on.

I’ve got a Jetson nano some days ago. i tried to turn it on but Jetson nano never turns on with whatever Micro-usb cable

I followed “Getting Started with Jetson Nano” .

I downloaded OS image on 128GB sd card by SD Formatter and Etcher on Windows 10

and connected HDMI, usb keyboard and mouse

I tried 5V = 2A, 5V = 2.1A , 5V = 2.5A , 5V = 3A Micro-usb adapter but nothing works !

Green Light is never on.

What can i do in this case ? i guess this is board failure?

Hi wlgns2223,

Please check my following suggestions in your nano kit,

1.Did you make sure the J48 jumper is not connected on your nano?
2.Does your SD card have 12 partitions?

if my above suggestions are correct in your board and still facing the issue ,then please connect a jumper across J48 and try to power up the Jetson nano using 5V barrel jack adapter.

If you are still facing the same issue then it could be board failure!

Hello velmurugan.s . Yes i am sure J48 was not connected since i also tried to connect j48 jumper cable and connect barrel jack . when i install OS image on sd card , i could see i had several partitions …

it seems that it is a kind of board failure …

Thank you for your reply !