Booting Problems


i just got my Jetson nano a month ago and i just had the time to try it up.

Flashed a 128gb micro sd card, wrote the image in it, followed the step from the nvidia website for the terminal part of the setup. inserted the micro sd card into the jetson, keyboard, mouse, hdmi and as last power supply. Led turn on and stays on but it wont boot.

i tried two different monitors, barrel jack(power led on the jetson turns of 2/3 seconds after i plugged it in) and micro usb as power supply, two different HDMI cables and still nothing.

Nvidia live chat support advised me to ask here if my Jetson is faulty.

Appreciate any help.


How about different HDMI monitor (not cable) here? Would it light up?

Tried 3 HDMI monitors(2 pc monitors and a tv monitor) did not boot but light on Jetson nano stays on

Are you able to dump the uart log?

or an alternative way is try to use sdkmanager to flash the board. We got some users report that the sdcard installed by etcher may have problems for some cards.