Green LED doesn't turn on after connect power supply

Hello,

I’ve received my Jetson Nano today.
According ‘getting started’, I connected power supply. but LED didn’t turn on and nothing happened.
any suggestions or comments or does anyone meet same situation?

I am using following peripherals;

also, I want to know what is the minimum requirement to turn on the LED.
I believe that is only appropriate power supply connection.
SD card, keyboards, mouse, display connection are not mandatory to turn on LED.
Am I correct?

Thank you

Hi ya9do,

You need to download the Jetson Nano Developer Kit SD Card Image, then write the image to your microSD card by following the instructions below according to the type of computer you are using. Please refer to:
https://developer.nvidia.com/embedded/learn/get-started-jetson-nano-devkit#write

Thanks

Hi, kayccc,

Thank you for your instruction.
Actually I followed every steps on that URL.

Especially on following #6 step,
Connect your Micro-USB power supply (5V⎓2A). The Jetson Nano Developer Kit will power on and boot automatically.
I connected power supply but nothing happened, no green LED, nothing shown on display.

Thank you,

Hello,

Let me share my try.

Fortunately, my colleague has another Jetson Nano.
We tried to connect power supply to confirm if Green LED turn or not.
and we confirmed it was on without any SD card installed.
I believe that LED on/off requires only power supply.

Thanks

Hi ya9do,

Since you have tried another Nano with the same power supply and it works on that unit, that could be device issue, please go for RMA for the problem unit:
https://developer.nvidia.com/embedded/faq#rma-process

BTW, please also update your RMA No. that’s for our team to track this issue further.

Thanks

ya9do,

Have you filed a RMA? Could you share the RMA #?

Hi All,

The green LED on my Jetson Nano does not light whether there’s the SOM or not and with USB-2A power supply or DC-4A power supply (J48 unshorted/shorted respectively).

Aside from the 5V, other voltages (3v3, 1v8) are not available.

Board :
945-13450-0000-000
S/N : 0421319035591

Any idea about possible problem, please?

K.

Hi,

Please open a new topic for your issue. Thanks

Are you trying to power your Jetson Nano with a USB cable, or with the barrel connector?

The barrel connector won’t work unless you add a jumper to the correct location. Without the jumper you must power the Jetson Nano through the USB port.

I didn’t find this information anywhere in the instructions. Nvidia should add this to their initial instructions, or they should design the board to just work without a jumper regardless of where you connect the power.

khang.letruongg7g8r, Your board appears to be broken.

khang.letruongg7g8r, Your board appears to be broken.

I contacted their customer service for the RMA process already.